1

I want to use this Genius keyboard with my 2014 MacBook Pro 15".

When connecting the keyboard, the Keyboard Setup Assistant opens, saying that keyboard could not be identified. Then, it asks to press the key on the left of right shift. When I press 'Z' key three times, it says that the keyboard still could not be identified and asks to chose the type of keyboard manually.

Despite of the answer, keyboard starts working improperly. When I press 'q' it types 'x', 'w' -> '4', 'e' ->'l', 'r' -> 'y', 't' -> '1', 'y' - '6' and so on. When I chose different type of keyboard (ISO/ANSI) nothing changes and the same wrong buttons mapping preserves.

The keyboard itself is working fine on other PC.

Would really appreciate your help to make it work.

1

The behavior sounds like a Num Lock or Fn key is stuck on. Does the keyboard behave this way on a PC without the Genius keyboard driver installed?

I don't know how much effort you want to put into this, but Karabiner is a general-purpose tool for remapping just about anything about a keyboard attached to a Mac. You can make rules which only affect a single device. How much do you like this keyboard?

  • 1
    Thanks for your answer! The keyboard works correctly on a PC without genius driver. I tried Karabiner and mapped several keys, but some of the keys don't produce symbols or actions when typed, and I can't track what they are responsible for to write down correct rules for Karabiner. Could you suggest any program which can track the pressed keys on system-level? I tried several keyloggers and Automator, but they don't recognize what keys are pressed. – Grigor Gevorgyan Jun 11 '15 at 13:43
  • 1
    actually even the keyboard viewer doesn't show what keys are being pressed when I hit numpad, arrows, etc.. so it seems system is unable to handle the signals sent by the keyboard. – Grigor Gevorgyan Jun 11 '15 at 13:52
  • Sounds like you're not getting a signal, full stop. A powered USB hub might be the next best step in troubleshooting this if you're really attached to the Genius keyboard. Personally, I would be looking in to a comparable Logitech keyboard with similar key stroke, or possibly a mechanical if you really like the feel of this particular keyboard. Note that my user experience with Genius peripherals has been that their products stop working for no discernible reason other than a faulty wireless adaptor. – Rampant Jun 12 '15 at 5:12
  • Agreed. Logitech is the way to go for keyboards and mice, among other things. – William T Froggard Jun 14 '15 at 22:48
0

Reset the PRAM: Parameter RAM stores the configuration of your system. There may be something stored preventing the keyboard from being identified by the Keyboard preference panel.

Shut down your MacBook Pro. Press the power button, then before the grey screen comes up, hold down CMD + Option + P + R simultaneously until you hear the chime. Continue holding them until your MacBook Pro restarts, and you hear the chime again, then release.

You may also want to reset the SMC after trying other options. The method used varies by model. From the article linked below:

• Newer Macs with built-in batteries

Shut down the system and plug in the power adapter Hold the Shift, Control, and Option keys on the left-side of your keyboard Press the power button while these keys are held, and then release all keys at once Start up the system normally

• Older portable Macs with removable batteries Shut down the system and disconnect the power adapter Remove the battery Press the power button and hold it down for 5 seconds Release the button, connect the power, and start up the system.

Apple does not recommend doing this often, however it can solve stubborn problems, especially with peripherals, and I've never seen any ill effects from it in the past 25 some-odd years of owning, using and abusing Mac portables, back when the SMC was a PMU.

http://www.macissues.com/2014/04/11/when-and-how-to-reset-your-macs-smc/

If that does not work, try plugging the keyboard into either a USB extension cable or powered USB hub, which seems, oddly enough, to sometimes solve this problem.

https://discussions.apple.com/thread/5470234?start=15&tstart=0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .