Mac OS 10.10.x

As in title.

I find this very annoying and want the OS to stop trying to think what I want to do - especially in this case.

  • Are you sure you're not doing this in Mission Control and the app is being assigned to a space? I use multiple displays with my Mac every day and don't experience this, but it could be specific to the application you are using. – NReilingh Jun 8 '15 at 19:43
  • I don'e know. What are your Mission Control settings. I try not to use it. I have set Displays have separate spaces to off and the Dashboard off as well. The only MC setting that is on is "Group windows by application". – Alex Zavatone Jun 8 '15 at 19:46
  • Try turning on "displays have separate spaces". What application is this behavior happening to? Or is it all applications? – NReilingh Jun 8 '15 at 21:12

You must log in to answer this question.

Browse other questions tagged .