So, I have a Macbook Air and I use it to talk to people through iMessage, but the messages appear on my iPhone 5c as well. How can I stop the messages coming through my iPhone temporarily but they can still go through my Macbook Air... Is this possible... Macbook Air, yes - iPhone, no please

thank you kindly :)

  • did you try Go to Settings > Messages > Show Preview to Off.
    – Ruskes
    Jun 8, 2015 at 2:42

2 Answers 2


In case you do not want to see notifications for iMessage, go to Settings > Notification Center and move Messages app to Not in notification center. Also disable Banners or Alerts for it, and set it to None.

Now Messages will not be showing on iPhone, but you will have a notification sound and unread number showing as Badge app icon. In case you dont want to be disturbed by a sound, temporary disable sound also.

PS. This will not showup normal SMS messages also, but you will get sound notification and badge.

Very fast temporary solution, is to enable Do not disturb mode on iPhone. Settings > Do not disturb. This will allow calls (if you set so), but disable all notifications until swithed off again.


You can turn iMessage on and off on your device in Settings > Messages, but I wouldn't recommend it for what you are asking to do. The short answer is no, you cannot disable messages being sent to a device without turning iMessage off for that particular device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .