0

I am using a MacBook Pro with OS X 10.10.3. I am a developer and I use FTP on a regular basis. However I am new to OS X. It was working fine but suddenly FTP stops working for all FTP clients on my Mac for any server, even for ftp://ftp.mozilla.org/. I use NetBeans and use its most native Java based client. I tried with Firebug, FileZilla, Firefox, Chrome and OS X's native Finder client. I tried with Terminal as well — the response is:

Tousifs-MBP:~ tousifosman$ ftp -v ftp://ftp.mozilla.org/
Trying 63.245.215.56...
Connected to ftp.mozilla.org.
421 Service not available, remote server has closed connection.
ftp: Can't connect or login to host `ftp.mozilla.org'

However I am able to connect to all the servers from my Windows platform.

  • What does the Ping 63.245.215.56 shows. In Terminal type Ping 63.245.215.56 and let it run. I get 20ms. – Ruskes Jun 7 '15 at 17:14
1

The occurred due to my local wifi network. It was some how blocking ftp. Replacing the router solved my problem

0

I do not normally use the FTP but here is the result for comparison.

~  ftp -v ftp://ftp.mozilla.org/
Trying 63.245.215.46...
Connected to ftp.mozilla.org.
220-
220-   ftp.mozilla.org / archive.mozilla.org - files are in /pub/mozilla.org
220-
220-   releases.mozilla.org now points to our CDN distribution network and no longer works for FTP traffic
220 
331 Please specify the password.
230-
230-   ftp.mozilla.org / archive.mozilla.org - files are in /pub/mozilla.org
230-
230-   Notice: This server is the only place to obtain nightly builds and needs to
230-   remain available to developers and testers. High bandwidth servers that
230-   contain the public release files are available at http://releases.mozilla.org/
230-   If you need to link to a public release, please link to the release server,
230-   not here. Thanks!
230-
230-   Attempts to download high traffic release files from this server will get a
230-   "550 Permission denied." response.
230-
230-   Low-traffic files, including SeaMonkey releases, are OK.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
200 Switching to Binary mode.

PS, I use FF as browser.

0

Had the same issue... it turned out I had a corrupted NAT table in my router so I could send requests to FTP servers but I did not receive anything...

One quick reboot of the router and computer later everything is fine. Very weird as everything else BUT the FTP connection worked just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .