1

I found a white plastic/ rubber 2009 Macbook in the IT Office of my school and was given permission to try to get it to be usable again. Currently, it is able to be charged with its magsafe connector and the indicator LED in the front turns on when I hold down the power button, but the screen never turns on and the keyboard does not respond. (i.e. the Caps Lock indicator button does not turn on.) After a few seconds of this, the fans start to make a lot of noise, but the computer remains unresponsive.

I tried plugging in an external monitor though the thunderbolt connector, but the monitor never picks up a signal. I tried plugging in a device though the USB ports, but this too does not work. I tried resetting the SMC as per that Apple website instructions, and this also does not work.

Is there any way that I could get the computer to boot up into the operating system? Any help would be greatly appreciated.

6
  • 1
    Did you try the usual, Safe boot, Verbose boot, Single user boot ? You will not have anything on the ports till the system boots. That battery should be EOL? can you check it.
    – Ruskes
    Jun 5, 2015 at 22:12
  • I tried some of these types of boots, but I don't think the screen is working and therefore wouldn't know if the boot worked.
    – Acoop
    Jun 5, 2015 at 22:32
  • You would know since the USB plugs should be now working, or the Cap lock light. Do you get the boot sound ?
    – Ruskes
    Jun 5, 2015 at 22:34
  • The boot sound has never played but i was thinking that this may be because the last time the computer was used the speakers were turned off.
    – Acoop
    Jun 5, 2015 at 22:41
  • Try hitting the screen brightness key (F2) to see if the laptop's backlight was off. The other symptoms you list are indicative of a massively munged machine. When the fans go on, do they stay on? When you try to insert a CD (use one you don't care to never get back if the CD drive eats it) does it smoothly ingest the disc or does it do nothing?
    – IconDaemon
    Jun 5, 2015 at 22:49

2 Answers 2

1

Did you reset both the SMC and PRAM (instructions is on the same support page at the Apple website)? If you did, try it once again.

Did you try all of the things in your post with both the power adapter and on battery?

Since the machine is old and there is no support warrant left at Apple I don't think there is any idea to contact them. Otherwise, you may have found the reason to why it was just laying around at the IT office.

5
  • Is there any way to interface with it without it having to boot up? For example, can I try to access it though one of the USB ports or through the ethernet port? And if I did connect up the Macbook to another computer, could I use terminal to try to troubleshoot it and possibly fix it?
    – Acoop
    Jun 5, 2015 at 21:21
  • @user3650087 Booting from USB is not possible here since we can't get any response from the machine. I highly doubt that it is possible to access it via USB or Ethernet from an another computer since we can't get any OS to boot on it. Just a thought I got, do you get any power out of any of the connections when you start it? Or could there be malfunctioning circuits involved?
    – Dempa
    Jun 5, 2015 at 21:30
  • It does not seem that there is any power coming out. I tried plugging in my iPhone but it does not start charging. I also plugged a USB stick in that has an indicator light but it also does not turn on.
    – Acoop
    Jun 5, 2015 at 21:34
  • @user3650087 Try plugging in an Ethernet cable (that is connected to something in the other end that will give a link) and see if any status lights start flashing around the cable (I don't remember if your MacBook model have status lights on the Ethernet port. If you don't get any lights there or any reaction from the computer in any other way + that resetting PRAM and SMC didn't work then I think it is time to start blaming the hardware.
    – Dempa
    Jun 5, 2015 at 21:39
  • I tried connecting the ethernet port to another computer with an ethernet port but the second computer said that it was not connected.
    – Acoop
    Jun 5, 2015 at 22:25
0

Since the computer seems to have a firewire port, you could try booting it up in Target Disk Mode (keep the T key pressed while booting). Basically, this means you will be booting this Mac from another Mac's hard drive. The main aim of the exercise is to make sure the rest of the computer is OK, you just have an OS corruption or bad hard drive.

Alternatively, if you can find an old Mac OS-X install DVD, you could also try to boot from that (keep the C key pressed).

3
  • I don't see any firewire port. Can the same be done through USB?
    – Acoop
    Jun 5, 2015 at 21:39
  • OK, so you have a Late 2009 MBW, support.apple.com/kb/SP579?locale=en_US Early 2009 models still had Firewire. No, sorry, booting in TDM does not work over USB. But if you have another hard drive with a copy of the OS on it that you know can boot, you can put that in a USB enclosure and boot from there.
    – ALAN WARD
    Jun 6, 2015 at 10:31
  • Just had a thought: you could also take the hard drive out of the Macbook, put it into a USB enclore, and try to boot another Mac from there. At least you would know if you have just a hard drive or OS error, and if the rest of the computer is fine. If its just the HD or OS, you are looking at an easy (and cheap) fix. Otherwise....
    – ALAN WARD
    Jun 6, 2015 at 10:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .