3

I run Google Chrome Version 43.0.2357.124 (64-bit) on OS X Yosemite.

I want to enable Click to play option, mainly because I would like to lower the power usage of Google Chrome and Google Chrome Helper processes.

However, I cannot find it under Settings > Content settings > Plugins and it should be there according to Why does Google Chrome Helper spike my CPU? and many other webpages.

Question:

Has Google decided to removed this particular Click to play feature from Chrome or for e.g. it has moved to some other section of the Settings?

One way or another, is it possible to enable Click to play option for plugins?

2

Google Chrome Version 55.0.2883.95 (64-bit) on macOS Sierra 10.12.2

It looks like the solution for Chrome 43 doesn't work any longer as the Let me choose choose when to run plugin content option is no longer present in the settings.

At the moment you can:

  1. Open Settings (you can do it by clicking More and then Settings or by clicking +,).
  2. Click + Show advanced settings.
  3. Enter the Content settings in the Privacy section.
  4. Go to the Flash section and choose Block sites from running Flash.

More information here: https://support.google.com/chrome/answer/142064?hl=en


Google Chrome Version 43.0.2357.124 (64-bit) on OS X Yosemite

Ok, so I've found it. It is not presented as Click to play any longer (it used to be in previous versions of Chrome and is still presented like this in Chromium).

If you want to turn this option on you've got to:

  1. Open Settings (you can do it by clicking and then Settings or by clicking +,).
  2. Click Show advanced settings....
  3. Enter the Content settings in the Privacy section.
  4. Enable Let me choose choose when to run plugin content in the Plugins section.

enter image description here

It seems quite obvious now, but I've been trying to find this for a few weeks by now, because it was called Click to play before.

  • Thanks for tracking this down. It looks as though when Click to Play was replaced my setting defaulted back to Detect & run important plugin content. Under this setting though, I haven't experienced the awful spikes I used to have. FWIW. – doub1ejack Mar 28 '16 at 14:48
  • 1
    I don't have this Plugins section. Chrome version 55.0.2883.95 on OS X. – shrx Jan 10 '17 at 10:57
  • @shrx I updated the answer. However, I'm a little bit confused now whether it still works the way it used to. – Mateusz Piotrowski Jan 10 '17 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .