In 'Settings' > 'Cellular': all the switches under 'Use cellular data for:' are grayed out. Some are ON and some are OFF but none can be changed. These are the switches that control cellular data usage for individual apps. Why are they disabled?

In the same panel I have 'Cellular Data' turned ON and "Enable LTE" turned ON.

  • I tried turning cellular data OFF then back ON again. I tried terminating a few of the apps that could use cellular data but can't because their switch is off, for example the Apple stocks app. (Terminate by double-press the home button then flick the image of the backgrounded app up and away.) I tried rebooting the device. That's about all I could think to try.
    – RobertL
    Commented Jun 5, 2015 at 23:37
  • try going to settings>general>reset and see if you can reset cellular settings... Commented Jun 6, 2015 at 0:09
  • That sounded like a good suggestion but I tried it and it didn't help. It caused a reboot and I had to re-enter the wifi password, so I know it did whatever it's supposed to do but all the individual app switches are still greyed out on the cellular usage screen. If you don't have any other ideas I'll take it to an Apple store and ask at the Genius Bar. I always wanted to ask them something they couldn't figure out. Maybe this is it.
    – RobertL
    Commented Jun 7, 2015 at 17:51

2 Answers 2


Looks like it's restricted —someone activated parental controls on your device.

Cellular data greyed out when restricted

Go to Settings > General > Restrictions and scroll down until you see the Cellular data item, you can deactivate it there (given you know the passcode).

On iOS 13, restrictions have been moved under Settings > Screen Time > Content & Privacy Restrictions

  • Bingo!!! You got it. I don't know how that happened. I'm the parent (well I'm the owner and there are no kids involved) so I guess I must have done it myself unintentionally. Maybe one of the system upgrades set the restriction on? I'll never know.
    – RobertL
    Commented Jun 9, 2015 at 5:51
  • There is no Restrictions under my General Commented Dec 20, 2019 at 18:53

If your device is jailbroken, try removing the following file on your device and rebooting:


Related: Cellular data app preferences not being saved

  • The device is not jail broken.
    – RobertL
    Commented Jun 5, 2015 at 23:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .