3

I found a great answer in the forums for an incorrect block count/invalid free block count problem that Disk Utility diagnosed when logged in but couldn't see in Recovery HD mode. Turning off FileVault as instructed by user10355 allowed me to repair the HD and after logging back in and even after turning FileVault back on, Disk Utility told me I was problem-free.

Now, 2 days later, I have noticed my MBP15 doesn't always go to sleep after a period of inactivity the way it should. I ran Disk Utility again and it found another set of incorrect block count/invalid free block count problems.

enter image description here

So I am going through the FileVault off decryption procedure again to hopefully be able to repair the problems.

My concern is that maybe this is symptomatic of a problem worse than FileVault. Is my harddrive (mid-2012) going bad? Or are repeated problems with FileVault to be expected?

In case it helps, the initial problem I had that lead me to run Disk Utility and discover the incorrect block count/invalid free block count problem and then find the FileVault solution was not being able to restart because Adobe Illustrator was supposedly preventing restarting. But Illustrator wasn't running and not visible to Activity Monitor. Force quitting did show Illustrator as a choice to quit but it wasn't able to quit it and therefore couldn't restart. So I had to restart by holding the power button down. Mentioning this because it's another sign to me things aren't right.

5
  • 1
    What application is responsible for creating those "IMG_####.MOV" files? I had an application once that was doing something it shouldn't, constantly corrupting my disk over and over. It seems something similar may be happening to you. Commented Jun 4, 2015 at 17:04
  • 1
    Also, this likely isn't a problem with FileVault. FileVault operates at an abstraction layer, separate from the filesystem on which the data resides. If there are any FileVault issues, it would likely result in massive or total data loss (although I've never seen any FileVault issues before), not a little localized corruption like you're seeing. This is an HFS+ issue, potentially caused by a faulty application or driver. Commented Jun 4, 2015 at 17:36
  • Thanks for the thoughts, @Froggard . I was curious about those IMG_####.MOV files too. iPhone videos but in a folder made by Google+ Auto Backup photo app. That app is a giant CPU hog for making my fan go crazy and I'd quit it more than use it. So after seeing the MOV file problem, I deleted that app and its files. So maybe that will be my answer there. Commented Jun 5, 2015 at 18:08
  • From your description, very possible. Commented Jun 5, 2015 at 18:10
  • And in the time since I posted the question the other day, I managed to repair the disk using Recovery mode. I haven't turned FileVault back on yet but am glad to hear that's not the likely problem. I ordered Disk Warrior and will run that from a flash drive next week and will hopefully get things cleaned up even more. Commented Jun 5, 2015 at 18:11

0

You must log in to answer this question.

Browse other questions tagged .