3

I upgraded my OS from Mountain Lion to Yosemite yesterday and now Mission Control and Cmd + Tab aren't working anymore. Clicking mission control icon doesn't do anything, although I still have 4 spaces automatically opened upon starting the computer. Also, for instance, when I am on screen #1 and Chrome is opened on screen #2, if I press Cmd + Tab to change to Chrome, the menu bar at the top of the screen will change to Chrome but the screen will remain on screen #1.

So far, I tried, but without success:

  1. Rebooting
  2. Killing dock process using "killall Dock" and "killall -kill Dock" in Terminal
  3. I made sure no other updates were available
  4. Browsed internet a few hours to try to find something, but found nothing successful
  5. F4 shortcut doesn't work neither

My computer specs are the following:

iMac 27 inches, late 2009, 2.66 GHz Intel Core i5, 8 GB DDR3

Would anyone have any suggestions?

  • you mean "killall -kill Dock" – Ruskes Jun 3 '15 at 17:01
  • I also tried it, but also unsuccessful in order to make Mission Control work, although Dock was reseted. Edited it. – A.P. Jun 3 '15 at 17:03
  • Is this User specific? and did you repair permissions in disk utility? does the mission contrl keyboard shortcut works? or the F4 – Ruskes Jun 3 '15 at 17:08
  • There is only one user on the computer, so I do not know, should I create a second user and try it? I do not know what those repair permissions are, I'll look at that. I also tried F4, but not working. I'll edit it concerning F4. – A.P. Jun 3 '15 at 17:21
  • 1
    Disk utility repair permissions did not change anything. – A.P. Jun 3 '15 at 18:05
4

Try resetting all the defaults for Mission Control. I had the same problem and now it works.

Type the following command into Terminal:

defaults delete com.apple.dock mcx-expose-disabled && killall Dock
  • 1
    Thanks for your advice, but sadly I have already downgraded back to 10.8 because I couldn't find anything. How can I mark my question so people do not loose time answering it? – A.P. Jun 10 '15 at 14:09
  • @A.P. - Your question still needs an answer. It will help other people. – Nicolas Barbulesco Jun 10 '15 at 16:35
  • This works for Yosemite with the following adjusted command: "defaults delete com.apple.dock && killall Dock". – Mark McKenna Sep 15 '15 at 22:51
  • This works with Mojave too! – NetOperator Wibby Sep 20 '18 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .