Poked at the system settings, display settings, and changed screen rotation setting to 180. Immediately after rotation setting became read only, and then after 30 seconds it crashed.

After reboot i cant'go to system setting any more, it just says to me that it cant open display settings and hangs.

NVRAM reset (options+cmd+R+P) does not reset screen rotation setting, only everything else.

So. How to do rotate display back to default? Command line options anyone?

Macbook Pro 13", 2013, OS X 10.10.2

  • Do NOT rotate your screen using command-alt-click on the Display preference pane. Hack/fix here: apple.stackexchange.com/a/104832/55028 Commented Jun 19, 2015 at 12:53
  • The fb-rotate tool mentioned in DamienG's answer worked for me when I had the exactly the same problem. Commented Dec 3, 2016 at 16:01
  • andrey rodin which app was this? Commented Feb 25, 2017 at 0:19

5 Answers 5


To reset the System Preferences:

  • Delete ~/Library/Preferences/com.apple.systempreferences.plist

If you don't see the Rotation Setting in the Displays Panel, try this:

  1. Close the System Preferences if it is open.

  2. Open System Preferneces

  3. option-command click on Displays

  4. You should now have access to the rotation settings.

  • No, it can't open display settings by all means. Commented Jun 3, 2015 at 14:09
  • Sorry, I read too fast. I updated my answer on how to hopefully reset the System Preferences so it doesn't crash.
    – Lee Joramo
    Commented Jun 3, 2015 at 14:18
  • deleting systempreferences.plist doesn't do anything... Commented Jun 3, 2015 at 14:34
  • You zapped the PRAM, have you booted in safe mode (hold down shift while starting up ) or logged into a different user account?
    – Lee Joramo
    Commented Jun 3, 2015 at 14:48
  • yes, i did all mentioned things. Commented Jun 3, 2015 at 14:50

Accepted answer didn't work for me but the following free command-line tool did;


Once compiled (see readme) just ./fb-rotate -d 0 -r 0

  • Even works on MacOS Sierra
    – Matt
    Commented Jun 14, 2017 at 16:02
  • Perfect! Worked like a charm. Thank you so much! Commented Oct 9, 2021 at 11:49
  • No longer works on Catalina, even with sudo - IOServiceRequestProbe: error 268435459.
    – lonstar
    Commented Oct 24, 2022 at 17:03

I ran into an issue where I could not load the display pane at all, even after multiple quits and restarts and PRAM resets; safe mode boot resolved it for me!


I have a MacBook Pro with macOS 10.12.3, did the rotation before I read this post. The way that I fixed it was doing a Safe Mode Restart. Was pulling my hairs out


I bought Pivot - Display Rotation on the Apple Store and it fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .