0

Sometime recently some file type names have changed — not the file associations or default application, but the name of the file type itself. "Plain Text Document" has changed to "text", "Rich Text Document" to "rich text (RTF)", etc.

"Incorrect" file type names

I did a find /Applications -name \*.plist -type f -print0 | xargs -0 grep "rich text (RTF)" and got hits in:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/System/Library/CoreServices/MobileCoreTypes.bundle/Info.plist

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/System/Library/Frameworks/CFNetwork.framework/CFNetworkCoreTypes-Info.plist

which do indeed list a whole whack of lowercase filetype names along with the offending ones.

And sudo find /Library -name \*.plist -type f -print0 | xargs -0 grep "rich text (RTF)" found (along with a bunch of "Permission denied"s):

/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 7.1.simruntime/Contents/Resources/RuntimeRoot/System/Library/CoreServices/MobileCoreTypes.bundle/Info.plist

/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 7.1.simruntime/Contents/Resources/RuntimeRoot/System/Library/Frameworks/CFNetwork.framework/CFNetworkCoreTypes-Info.plist

Anyway...is anyone else seeing this? And/or see how it can be fixed/restored? Granted it's almost entirely aesthetic. But if aesthetics weren't important to me I wouldn't be using a Mac. :)

  • So which Terminal command did you use to change the files from Plain Text to RTF. – Ruskes Jun 3 '15 at 4:10
  • I didn't do anything to them. Those are .txt and .rtf files that previously showed as "Plain Text Document" and "Rich Text Document", respectively. – KT_ Jun 3 '15 at 4:19
1

You must have a different text app associated with .txt files.

The "kind" will depend on the app associated (Open with) with that file type.

If you use the TextEdit, those will change back to Plain Text Document.

  • Unfortunately, no, that's not the case, as you can see here: imgur.com/NCAS8nV – KT_ Jun 3 '15 at 6:28
  • That is fine with RTF, how about your problem with the .txt files (Plain text) – Ruskes Jun 3 '15 at 7:59
  • Thank you the suggestion, but perhaps you are misunderstanding. Normally RTF files appear as "Rich Text Document". Now, as of relatively recently, they are appearing as "rich text (RTF)". And plain text files, which were appearing as "Plain Text Document" are now appearing as simply "text". Something has overridden the type names as specified in, for example, TextEdit's Info.plist. I'd like to figure out how to un-override it. – KT_ Jun 3 '15 at 8:07
  • Sorry for misunderstanding. Just checked, so what is the date on your TextEdit Info.plist file. I have Feb 2 2014. – Ruskes Jun 3 '15 at 8:37
  • Yeah, mine was 2014, too. I touched it, though, as well as the localized .plist in Resources/English.lproj in the faint hope that might give it precedence over whatever else was overriding it. For some reason, another setting from somewhere else is somehow taking precedence over what, for instance, TextEdit defines. – KT_ Jun 3 '15 at 14:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .