1

Frustrated by years of iTunes for Windows quirks, I finally bought a Mac Mini as a sort of media server and moved all my iTunes content over, including wifi-syncing my iPhone and iPads. I figured that iTunes would work better on a Mac.

Nope! Now, when watching a movie full screen, iTunes pops back up into the foreground whenever a device starts syncing. And the movie viewer can't be found again -- I guess it's on a different desktop?

Is this just a bug? Is there a workaround? Seems pretty odd that iTunes can't play movies full screen if there are iOS devices in the house. Surely that's not a design choice?

  • 1
    did you enable in itunes pref the keep movie on top? – Ruskes Jun 2 '15 at 2:44
  • You called it. If you want to post that as an answer I'll accept it. Grumbling in the comments: Why on earth would I want my little sync window to interrupt me while I watch a movie?? Surely that's not what the option was intended for! – Graham Charles Jun 2 '15 at 5:59
2

The follwoing setting should do it.

iTunes > Preferences > Advanced:

Check "Keep movie player on top of all other windows"

itunes

  • Whoops! Turns out that this doesn't work after all -- the little "sync window" still forces the iTunes library to the foreground, even when this option is set. – Graham Charles Jun 2 '15 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .