0

I am trying to setup gmail on a clean install of Mavericks 10.9.5. The Gmail settings like enabling IMAP etc are all set.
So now I am ready to add a new account in my mac, by going in System Preferences -> Internet Accounts and click to add a new Google Account.

Entering the email address and password and clicking the ok button, I am getting immediately an error message in red: "A connection error occurred".

I am trying the same directly in Mail app, still the same. There is no 2step verification and all security settings in Google account are setup so the connection should work. I have also unblock access via the Google Unlock Captcha. But yet I am not able to create my account.

Also, if I try to use a wrong password or username, it immediately tells me that my credentials are wrong, so it seems like there is a communication with Google, but something goes wrong with the Auto-creation of a Google account.

  • @Buscar웃SD:: The thing is that the account creation is being tried from the System Preferences -> Internet Accounts -> Add New Google Account, or from the same in the Mail App. Following these options the Google account is about to be configured automatically by only giving the email and password, while us the users don't have any participation at the settings. And the issue is that it can't pass this first step at all, returning this error. As said in my answer below, there was no problem auto-configuring the imap account, using the Other Account option in Mail app. – FFrewin Jun 1 '15 at 19:29
  • I see now that my question can be a bit confusing at the part where it says Gmail Settings are all set. I meant that I have done all the required settings inside Gmail (enable IMAP etc). – FFrewin Jun 1 '15 at 19:32
  • @Buscar웃SD:: This guy here had the exact same issue. We posted our questions at the same time. apple.stackexchange.com/questions/189562/… – FFrewin Jun 1 '15 at 19:36
  • @Buscar웃SD:: I agree, a corrupted OS X installation could be the reason. I won't have the time to re-install Mavericks at this time. I am more into upgrading to Yosemite. Most likely, it shall fix the issue if its system related. – FFrewin Jun 1 '15 at 19:42
2

Just to compare the settings: (assumes you already Enabled the IMAP in the gmail).

  • Incoming Mail (IMAP) Server - Requires SSL

    imap.gmail.com
    Port: 993
    Requires SSL:Yes
    
  • Outgoing Mail (SMTP) Server - Requires TLS

    smtp.gmail.com
    Port: 465 or 587
    Requires SSL: Yes
    Requires authentication: Yes
    Use same settings as incoming mail server
    

Full Name or Display Name: [your name]

Account Name or User Name: your full Gmail address (username@gmail.com).

Google Apps users, please enter username@your_domain.com

Email address: your full Gmail address (username@gmail.com) Google Apps users, please enter username@your_domain.com

Password: your Gmail password

  • That's a helpful post for anyone that might arrive here searching on setting up his gmail. +1 for the good thought. – FFrewin Jun 1 '15 at 19:20
1

Update - Recommended Solution:

Upgrading to the latest Yosemite version, resolves the issue.


How I dealt with it prior to upgrading to Yosemite:

The way I managed to overcome this was by setting up a new email account for gmail in mail by using the Other account option, instead of the Google option.

I have no clue about what is wrong with the Google Account option in Internet Accounts of System Pref and the Email app, but going with the Other email account option worked flawlessly, and it even auto-discovered and configured the gmail iMap mail settings.

For others that might have similar issues here is a brief list to review:
- Make sure that iMap settings are enable.
- If 2step verification - create an App/Device password to use.
- Sometimes Google needs some guidance. Visit: https://accounts.google.com/displayunlockcaptcha from the machine you are trying to connect, log in to your account and follow the steps/instructions.
- Try the Other Account Option and even configure manually the gmail account in mail app if it can't auto-discover settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .