I was trying to boot 4 linux OSes (using rEFInd): Kali, Ubuntu, Mint and Elementary on my 2015 MBP. Both Kali and Ubuntu would not boot at all and Linux Mint and Elementary would boot however some text, graphics and images would not show (tested on a PC and virtual box and it worked).

How would I fix this issue? Do I need drivers or something else? I cannot see the text to connect to the network and the Applications will not show correctly.

  • 1
    Unless you really need direct access to the physical Apple hardware, IMO, Linux runs much better in a virtual machine on a Mac then a physical install on a Mac. I use VMware Fusion as it's more refined then VirtualBox. I'm mentioning this because I too tried running Linux Mint 17.1 on an early 2013 MBPr and had issues that I just didn't feel like trying to fix when it runs just fine in a VM. – user3439894 Jun 1 '15 at 17:27
  • I want it so I can view my Raspberry Pi's SD card and use the cfdisk,fdisk and parted on it too. I may also use the commands to make my rEFInd partition smaller too. I would also like to do it just because I can. :) I did think about VMing it though. – iProgram Jun 1 '15 at 17:29
  • Was able to EFI boot Ubuntu on my 2007 iMac for the first time yesterday. Considering this Mac does not have a UEFI, I consider this quite an achievement. I was also able to configure rEFInd to boot Ubuntu via grub. Runs considerable faster then when I tested using VirtualBox. – David Anderson Jun 2 '15 at 11:46
  • Elementary says it is Mac comparable. Elementary also has EFI support. Do you know how to help me. – iProgram Jun 2 '15 at 12:45
  • If you want another user to see your comment, then you have to include a @ character followed by a username. For example: @DavidAnderson. – David Anderson Jun 2 '15 at 18:39

You must log in to answer this question.

Browse other questions tagged .