22

Lately, I've been getting this unusual "clone" of the Chrome icon appearing at the left side of my Dock. It comes out randomly. Initially, I thought it's a new feature that binds the iPad session on Chrome to the one in Mac.

The position is very odd (left side of the Finder). And whenever I click it, it merely opens a random commercial site. That's when I felt suspicious.

Is this a new feature that simply needs to be disabled, or is this a malicious program? Any idea how to remove this?

weird popup

  • Can you open Google Chrome normally without this showing up?? Is your iPad connected to your mac? Try checking your chrome extensions if there is something. – TheBro21 Jun 1 '15 at 11:52
37

That is Handoff and a natural feature when OS X and iOS devices are signed into the same iCloud account. This works if you have iOS 8+ or OS X 10.10.x Yosemite. If you have a supported application then you will be able to open it on your Mac right where you left off on your iOS device.

Looks like you was running Chrome on your iPad at the time.

If you wish to disable Handoff on a Mac, open 'System Preferences' and select 'General'. It's the check box labeled "Allow Handoff..." towards the bottom of the window pane.

If Bluetooth is off, Handoff is disabled as well.

  • Thanks @iProgram. My concern is that the site Chrome is 'handing off' is a site I have not even visited myself. What I sense is that one of the many open tabs in iPad may be launching a popup behind the scenes. I'll observe the pattern more. Already happy with the fact that this is not malware. – Ronixus Jun 1 '15 at 12:54
  • 1
    It may be that it is a link opened from another website that sometimes redirects you. – iProgram Jun 1 '15 at 14:43
  • That's fair enough, but its pretty annoying how it keeps showing and hiding and showing and hiding (and I don't know if its just mine or if this is just how it works). I am turning it off just cos its super distracting. – Kris Adams Dec 9 '15 at 15:31
-2

It's something called Handoff apparently. If you go to system preferences, then general, you can choose to disable Handoff. Turning off Bluetooth works too.

:)

  • This adds no information that wasn't already better explained in the accepted answer. – Tetsujin Sep 5 '16 at 8:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .