11

When you enter a FaceTime call in OS X, as of Mavericks, it lowers the volume of everything else besides the call. There's no way to disable this "feature." People here suggested disabling audio ducking in Voiceover Utility, but that doesn't have any effect, at least not in Yosemite.

Any suggestions for a hack solution to fix this? I don't want to install some system-wide audio mixer to help, but I'll happily mess with the FaceTime application or some system settings. I'm guessing there's some library it's using to control the system volume, and I'm trying to find a way to prevent the app bundle from accessing it.

13

Open FaceTime app (don't make the call yet), Paste the following line in to terminal,

printf "p *(char*)(void(*)())AudioDeviceDuck=0xc3\nq" | lldb -n FaceTime

and then make the call.

  • 1
    I just get current process state is unsuitable for expression parsing when I try this. – Hassan Mar 1 '16 at 0:01
  • 9
    I get error: attach failed: cannot attach to process due to System Integrity Protection when trying this. – duncanc4 Jul 28 '16 at 9:32
  • 2
    +1 to @duncanc4, System Integrity Protection renders this hack completely useless. – Andrey Tarantsov Aug 18 '16 at 17:33
  • 1
    @Edward The code patches the FaceTime binary in memory, overwriting the first byte of the internal AudioDeviceDuck function with a RET instruction, so that the function immediately returns without doing anything. – Andrey Tarantsov Jul 21 '18 at 14:43
  • 2
    Has anyone gotten this to work on MacOS Mojave? I'm on 10.14.3 and it is not working for me. – CoBrA2168 Mar 1 at 18:30
3

Go into the "Voiceover Utility", go to the "Sound" tab and uncheck "Enable audio ducking" checkbox.

  • That only applies to the Voiceover Utility... – Francisco Aguilera Apr 17 '16 at 5:54
  • 3
    This didn't work – Miguel Mota Dec 22 '17 at 7:30
1

after being stuck with this problem for a looooong time, I finally found a way to solve it without disabling System Integrity Protection.

  1. Buy Loopback app from Rogue Amoeba.
  2. In FaceTime app, pick Loopback virtual device as the output.

Not affiliated with the developers, just a happy user who can't believe that this has finally worked.

  • I think Soundflower would work as a free alternative. Or, in general, any output that's not the same as your default one that you can still hear. I used to use a separate pair of headphones. – sudo Mar 16 '18 at 17:16
0

VoiceOver Utility -> Sound -> Disable audio ducking.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • "Audio ducking?" – Allan Jan 17 at 10:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .