2

I have an app that was built by vendors. They did everything including submitting the app to the App Store. So now I did slight modification to the app and want to update it in the app store. However, an error message pops up when we try to archive the app in Xcode. It first says that the team doesn't match, then prompts me to click fix it. I clicked fix it but finally it shows this message:

Your account has a valid iOS distribution certificate but it is not installed locally.

What does this message mean and how to fix it?

I'm using Xcode 6.2. I have installed the Development and Distribution certificates on my Mac. Still getting the same error message.

This is my first hands-on experience in building iOS apps and deploying them to App Store.

How do I resolve this issue?

1

You have to go to https://developer.apple.com and enter in Member Center.

Then:

  • Certificates, Identifiers & Profiles.
  • Certificates.
  • Provisioning Profiles / Distribution.
  • Select the certificate you want to use and Download.
  • Doble click once downloaded to install it.

That should solve your problem.

  • I did that to every certificate in the dev center, yet I still get the same message. – ElSSS May 31 '15 at 10:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .