Situation: when I'm at my desk, I have speakers plugged in to my Macbook Pro and everything is working fine.

The problem occurs the next time I boot the computer without speakers connected: I'm now unable to mute or change the volume at all, it's set to maximum and greyed out (see screenshots in attachment).

I can solve this by plugging in some headphones, father that the option becomes available again. After that, it works again but the problem reappears after a reboot.

I've had this machine for about 2 years now, haven't had this issue until I installed Lion (first the GM release and now the version from the App store) so this feels like a software issue. I didn't upgrade to Lion but did a clean install and I've tried it with another user account as well, same issue.

Any suggestions?

enter image description here

enter image description here

  • You could boot to an old 10.6 installed DVD just to see if that OS is muted too. You don't have to actually install anything - the hardware should fail identically on either OS (assuming it's hardware) You'll have your smoking gun if you can reproduce it in Lion versus Snow Leopard several times in a row.
    – bmike
    Jul 27, 2011 at 15:52
  • 1
    Those disabled volume control indications occur on digital outputs, and MacBook headphone jacks can act as optical digital outputs. Your system thinks there's an optical plug connected for some reason, and if you look at the jack you'll see a red light. I don't have any suggestions on how to fix that (the one time it happened to me a plug/unplug fixed it), but maybe this will help you find an answer.
    – Kevin Reid
    Jul 27, 2011 at 22:51

2 Answers 2


If you are seeing the greyed out output volume when no headphones or plug is physically present than the physical switch to detect a plug missed the unplug event.

The system things you still have speakers connected and is routing the information to the jack.

Check for lint with a magnifying glass or very gently blow some clean compressed air. Service might be an option if this is something that happens very often.

Responding to the comments about this happening each time at reboot, that would indicate that the hardware is somehow saving headphones on as a default setting or the hardware is mis reading things at boot. Resetting NVRAM might help if it's a saved setting issue.

There are only 3 things in play here:

  1. The physical package in the jack that is responsible for sensing if anything is inserted and telling if it's a metal jack or an optical jack.
  2. The brains of the hardware - storing settings in NVRAM and turning the physical sensor into something the software can show you on the screen.
  3. The OS - Lion or Snow Leopard

I would be very surprised it's Lion related - but I've seen strange things before where software doesn't make the correct read on a sensor. It's good you can restore things temporarily by plugging / unplugging a jack. If you took it to a repair shop, they would hopefully test your mac with Snow Leopard again to rule out lion before doing an actual repair on the jack or the hardware. If this is something you can depend on - it happens each and every time, you might test by booting from a backup or installing Snow Leopard onto a USB drive and testing. It sure sounds like an odd but reproducible thing you have happening to your mac.

  • I've checked with a loupe and blown in out with compressed air, issue still occurs. I've also not seeing the above mentioned red light when the problem occurs. Aug 6, 2011 at 11:45
  • pluging and unplugging the head set solves this problem. thanks so much.
    – bgs
    Aug 14, 2011 at 6:25
  • Yes it does solved the problem, the question is how to prevent it in the first place. I don't always have headphones with me (ok, not true) and I don't want to have to plug them in every time I reboot my laptop. Aug 14, 2011 at 14:52
  • If a reboot is causing it to be "wrong" most or all of the time, then two things jump to mind. 1) The NVRAM has stored the wrong saved sound settings - resetting it once (hold Command-Option-P-R at boot till you hear the boot chime a second time) 2) The switch is stuck down (failing) and the removal of the headphones lets it realize a headphone is actually gone (the port needs to be repair as this isn't the correct behavior you expect)
    – bmike
    Aug 14, 2011 at 14:57
  • 1
    Meanwhile, running 10.7.2 solves this for me, haven't had the problem since the upgrade. Nov 3, 2011 at 5:59

This problem is related to shutdown. If you shutdown with headphones connected and restart without them you'll have this issue on some hardware.

Entering a headphone will enable audio (through headphone off course) removing it again will disable the output again. Only a reboot without a jack connected will reenable normal audio output

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .