0

I was given an old retired Xserve 2008 model. This model cannot officially run Mac OS X beyond Lion Server. I have tried the tricks to get later OS X versions to boot on it, and while it works, the latest versions of OS X Server do not support this hardware - for example, most of the remote management features (power/fan/CPU speed/disk health/etc) do not work, as Apple considers this unsupported hardware.

I would like to run Windows 2012 Server R2 natively on this hardware. I know that installing into a VM would be an option, but I am not licensed for versions of Fusion old enough to run on Lion, and Virtualbox has been a mixed bag for me. I also would probably lose some performance here... And the issue still stands that I'm running a severely outdated underlying OS that Apple isn't going to issue security updates for.

Now I know that running Windows natively on here won't give me that server management on Apple's side, but there's plenty of Windows tools that can do essentially the same thing provided the hardware is detectable under Windows.

I know that Xserves do not have the BIOS emulation layer that most Macs use for Boot Camp support, but I was wondering if it is possible to use EFI Booting to boot Windows 2012.

I've tried so far to do the following:

  1. Create a LiveUSB Linux device from a recovery distro which boots via EFI. This works. I am able to boot into Linux. The older graphics hardware seems finicky, but it does seem to run. This shows that there's enough EFI here to boot a non-Apple OS.

  2. Create a Windows 2012 R2 boot DVD for installation. This completely fails - holding down Option does not show the DVD at all in the boot options.

  3. Create a Windows 2012 R2 boot USB device using the NTFS file system. This does not work - guessing it's because Apple's EFI can't read NTFS (as most can't). The problem is that the 2012 R2 installation .WIM file is larger than 4GB, and while there's ways to do split WIM files (SWM), Microsoft explicitly states you can't install from one of these.

  4. Try creating a standard Windows 8 x64 boot USB device on FAT32. This should theoretically work since the Windows 8 install image is only about 3GB. This does show up in the boot options, but when it's selected, a black screen occurs and no further movement occurs.

It would seem that either I'm missing something, or that somehow this EFI implementation specifically refuses to boot Windows.

Most of the posts around the Internet chastise the poster for even considering this option ("Why would you want to do this! Get a PC server for God's sake!"). While they would have a point for new systems, this box is still very serviceable with its dual quad Xeons and 16GB of RAM and SAS drives - and Apple has only dropped support for it due to video card support.

My next step would be to try two things: to install Windows to a SATA drive using an EFI compliant system in order to get a drive that's EFI compliant that boots Windows and shove that in the Xserve to see if it'll boot it; and also to install the EFI GRUB loader onto the Windows install flash drive and see if it can coax the Windows loader into running. But before I go through all that... is this even possible? Or has Apple done something to block this from even being possible using native EFI?

I'm already aware that there may be driver issues due to lack of Boot Camp support, but from what I've read, the Xserve is more or less a Mac Pro in a 1U rack case, so I'd expect manually extracting the drivers from the Boot Camp distribution that works on the Mac Pro would likely yield many of the necessary drivers which could be installed by hand.


Edit: This appears to be related to the video card. A Linux installation I tried to make to the raw hardware resulted in a black screen as well. After poking around for a while, I figured out that there seems to be an issue when the Linux install tries to flip the video card into a more "native" video mode. I got Linux to run by disabling all of its video stuff, and basically letting the EFI video driver maintain control.

I'm not sure exactly what could be causing it, but perhaps it has something to do with the machine thinking there's multiple displays attached (when there actually isn't), or that the Apple video card is using some completely non-standard video modes...

So my guess is that the Windows installer may in fact actually be booting, but that I just can't see it because the display isn't presenting it...

My next step would be to try preinstalling the OS onto a SATA Disk as I explained above, however this still wouldn't be a solution, as I would not have any video output in order to install the network card drivers...!

I could definitely install Linux + VMware, or even ESX server, but I would lose some of the raw hardware level optimizations available - network card, SAS disk hot swapping, etc. at the OS level. This is why I still would preferably want to run Windows Server natively on the machine...

1

Just a thought here, but if you can boot Linux, why not install ESX 5.5 (it's free to use in base form) and then just one VM, your Windows Server.

ESX has a very low overhead and you should get most of the oomph you need out of Server 2008r2.

The only question that remains is, "will ESX 5.5 install on an XServe?"

  • I can confirm that esx 5.5 can run. Haven't been able to get the storage controller to work yet. – tron_jones May 30 '15 at 0:16
  • I'm not too familiar with ESXi, but do you still get any hot-swap capability? It'd be nice to retain the ability to pull drives out without downing the entire system or the VM. One way native booting of Windows would be nice. In the end if I can't get Windows to work at all I may just go with Linux, but just thought it'd be easier for my application because Linux still can't be remote-managed with Windows tools (a la Core Server) and while Samba is certainly a big help, it's still not on parity with Windows. – fdmillion May 30 '15 at 0:35
  • @tron_jones The SAS controller is identified via lspci as follows: "0e:02.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1064 PCI-X Fusion-MPT SAS (rev 03)" I feel like the Fusion MPT controllers are somewhat common? – fdmillion May 30 '15 at 0:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .