6

iCloud Photo Library appears to be working great between iMac and an iPhone 5c, but has been stuck on "13 items to download" for over a week on iPhone 5s, plus no photos taken with that phone have been uploaded in some time. Any ideas?

2

Turn your iPhone off and the back on. If that doesn't help, disable iCloud Photo Library and then turn it back on. If that doesn't help, logout entirely out of iCloud and then re-enable it.

  • 1
    I would wait 15-30 minutes between turning iCloud Photo Library off and back on, and similarly between logging out and logging back in. – tubedogg May 30 '15 at 16:34
  • Turning the phone off and back on appears to have gotten things moving again. I'll know more tomorrow morning, it seems. Thank you! – Ted Sarvata May 31 '15 at 4:59
1

None of those activities working so I had to bring my iPad Air 2 to a local retail Apple Store just to get an advice of performing a full backup, erase then restore the iPad from that latest backup and if it's still not working then bring it back and they will replace a new iPad under warranty. I did follow and fortunately it worked so saved me some more hassles with this defective iCloud photo album thingy. Hope Apple will fix it in the next iOS release...

0

I found that by enabling the 'ask to join new networks' option on the WiFi setting the phone could 'find' the Mac again. Quickly uploaded all images after that.

-1

Turn your WI-FI on on your iphone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .