1

For the past month or so, I've been unable to backup my iPhone using iTunes.
Every time I try, I'm told that the phone is "disconnected":

enter image description here

What could be causing this?
I've tried different USB cables and different USB ports, but the result is always the same.


I'm using OS X 10.10.3, iTunes 12.1.2.27, and iOS 8.3.
The procedure I'm using is the obvious one: launch iTunes; connect the iPhone; choose the iPhone in iTunes; press "Sync".

  • Could this be a hardware problem? I had an iPhone with a curved port so it disconnected almost every slight move. – TheBro21 May 27 '15 at 11:41
0

If you've tried all physical options, removing hubs, changing cables, ports etc, then the remaining likelihood is that the existing backup is corrupt.

Simplest method would be to find your backups folder & rename/delete the corrupt one, then test again…

  • Disconnect phone, quit iTunes
  • Switch to Finder
  • Cmd ⌘ N for new window
  • Cmd ⌘ Shift ⇧ G for Go To…
  • Copy/paste ~/Library/Application Support/MobileSync/Backup/ & hit Enter ⌅ or Return⏎
  • Change the name of the folder with the long, complex number - just add .bak or something to the end of it. (If there are multiple folders, see the note at the end)

  • In iTunes, try a new Backup, then Sync.

  • If successful, you can delete the old .bak folder

If you have multiple backup folders…

  • If you only ever backup one iDevice to iTunes, rename all the folders the same way, add .bak etc
  • If you backup multiple iDevices, you can find which is the correct folder by matching the device identifier with the backup folder name by clicking on the Serial Number field in iTunes (which will switch it to your device identifier.)
  • 1
    This seems to have done the trick! – orome May 29 '15 at 11:11
  • UPDATE: It doesn't work after all. – orome Jun 2 '15 at 11:01
  • There's always an outside chance of something in the initial backup. Not sure what else to suggest – Tetsujin Jun 2 '15 at 12:56
  • Yeah, who knows. I've deleted all old backups, but that doesn't fix it. Apple's software is getting buggier in general, so I think this is probably just part of that. – orome Jun 2 '15 at 13:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .