I tried downloading Tumblr yesterday but it never completed. At the moment I have an App icon stuck at 'Loading...'.

I have tried restarting the iPhone (holding down both home and side buttons at the same time) and I have also tried shutting down the iPhone (holding the side button and swiping).

I have also tried deleting it as usual (holding the icon down and choosing delete but it doesn't go away).

Any ideas on what I can do to get rid of this icon?


8 Answers 8


Go to SettingsGeneralStorage & iCloud UsageManage Storage, select the app from the list, then tap Delete App.

  • 2
    It's now Settings > General > Storage & iCloud Usage > Manage Storage.
    – Manto
    Commented Dec 15, 2015 at 0:04

Here is the real solution:

On the surface, some of what others have posted is correct, but may not help you because you don't know which apps are the blockers. The underlying problem is that all available download threads (was 10 for my iPhone SE) are being blocked on apps which either: 1. no longer exist in the app store or 2. are not compatible with the version of iOS installed on the device.

After repeatedly pausing the downloads and going into the AppStore to "reset" the download state and rebooting, you can whittle yourself down to where there are only 10 apps waiting and they are all as I described. From here, after a restart, if you start clicking on them you'll actually get the root-cause error message saying the app can't be installed and it will give you an option to delete it.

Then when there are NO apps in the download queue, reboot one more time and you'll be able to go into the App Store once more and re-initiate downloads for your remaining apps that are still compatible and available.

VERY painful, but this works.

  • Had this problem with iOS 12.1.1 after a restore from iTunes. At least a hundred apps stuck in "Loading…" limbo. After multiple different approaches to solve this (over several hours) - finding & removing the offending apps (all older apps that were 32-bit and/or no longer in the app store) started the install process moving again. Commented Dec 4, 2018 at 3:20

Certain apps might be frozen with a blank icon and their will be no way of removing them for days. By holding down on the home screen to delete the stuck app also won't work..

Here are instructions on how to delete these waiting applications:

  1. Reboot your iPhone normally. See this link for instructions on how to restart your iPhone.

  2. If the apps are still stuck on the home screen, try logging out of the App Store temporarily. Navigate to Settings -> Store -> Apple ID -> Sign Out. Now open the App Store and Navigate to the Featured section. Scroll to the bottom of the page and touch the Sign In -> Use Existing Apple ID. Log in and the stuck apps should reset.

  3. Still have strange icons on the screen or frozen downloading apps? Connect your iPhone to the computer and open iTunes. Navigate to the app store. Install the apps you are having a problem with on the computer then sync your iPhone.


Don't want to connect to iTunes or delete and re-install the app (along with all the settings you may have customized?) Try this:

  1. If the app update got stuck at Loading... because of insufficient space free some: Settings... General... Storage & iCloud Usage... Storage: Manage Storage. Find a hog; either delete the app entirely or go into that app and manage its internal storage. (I find podcasts consume a lot and I will delete downloaded media files to free up space; or I will delete immediately (not just in 30 days) some unneeded pictures.)
  2. Reboot the iPhone
  3. Go into App Store, re-select Update All. It will appear as though you are stuck again.
  4. Touch the update circle of the app that is stuck; the circle will switch back to the Update button.
  5. Select Update button and now the app update should complete.

App or other window stuck in "loading" mode. Turn off/disconnect WIFI and then turn back on, should fix problem. Otherwise Go into "General" in "Settings", then Usage, then Manage Storage - should see a list of apps, delete it (the stuck in 'loading' mode one) and then reinstate it (turn it back on).

  • Thank you SO much ZED!! for - "App or other window stuck in "loading" mode. Turn off/disconnect WIFI and then turn back on, should fix problem. I deleted the three or four "stuck in loading" icons and shut of wi-fi in "settings" and powered the iphone 10 off.Waited about a minute and re-booted and then went to Aps Store and downloaded an ap!!! YES, it quickly downloaded and loaded onto phone...did this with three aps...all worked just as you suggested!! GREAT huge relief and help from you! Thank you !!
    – familycat
    Commented Apr 13, 2018 at 3:41

I found this as help: In AppStore - search for this app, press on the button which download (it won't download it again, but slove the issue).


I found the culprit to be Google calendar. It was waiting for me to log into Google. Once I logged in this app loaded then all the rest loaded.


I found out that the problem is caused because too many apps are being loaded at the same time.

What i have done is that i paused all of them and then load one or two and it worked!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .