I have an iPhone 3GS with firmware version 3.1.3 running on tethered jailbreak (blackra1n). Yesterday the wifi didn't work so naturally I:

  1. reset network settings (as I did once or twice before).
  2. got the recovery mode screen (as expected).
  3. Connected it to my laptop.
  4. ran blackra1n.

and then, instead of booting like it normally does, my iPhone just rebooted itself and went back to recovery mode. I tried doing this several times with no luck. Has this happened to anyone? Any solutions?


Edit: This is pretty urgent, as currently I don't have a cell phone, so I would appreciate even half-ideas if you have any and don't have time for a full answer.

Update: I have restored my iPhone, but now I am stuck on activation, and can't seem to solve it. Tried using redsn0w, but it's stuck on "Waiting for reboot" after the second upload. Any ideas?

Update 2: Got redsn0w to complete the process, but after it finishes, it just goes back to the iTunes/emergency call screen...

Update 3: I was able to perform restore to 3.1.3, but now I just get the apple logo and it doesn't do anything... It seems problems are just piling on...

  • Have you recently downgraded from a previous OS?
    – Thomas
    Jul 31, 2010 at 21:33

4 Answers 4


I've had this happen once before. Is your phone in an "endless loop" of reboots? If so, my solution was to put the phone in DFU mode and restore it and just try the jailbreak over again. Sometimes things get loopy and it just doesn't work correctly. Give it another shot.

How to Put an iPhone Into DFU Mode

  • @snicker Won't the restore insall iOS4? Also, what about my data?
    – Amir Rachum
    Jul 31, 2010 at 16:38
  • 1
    @amir: You can download older versions of iOS, and if you press shift (or option on mac) and the restore button you can select a different IPSW. You can use google to find older IPSWs, like 3.1.3
    – snicker
    Jul 31, 2010 at 17:19
  • @snicker: He has a 3GS. If he doesn't have his SHSH on file with Cydia, he can't restore to 3.1.3.
    – Macha
    Aug 2, 2010 at 16:23
  • 1
    @Amir If you use iOS4 you can still jailbreak as of today ( jailbreakme.com )
    – Macha
    Aug 2, 2010 at 16:24
  • @Macha thanks! this worked for me. If you post this as an answer I'll accept.
    – Amir Rachum
    Aug 4, 2010 at 7:15

I had a similar issue with my 3G and was never able to get out of recovery mode, even with DFU mode. Luckily since I used blackra1n I still had the stock apple splash screen, and I was able to take it into the Apple Store where they exchanged it for a new one no questions asked. If you still don't have any luck getting it out of recovery mode, the Apple Store is definitely worth a shot.


Try restoring using iOS4, and jailbreaking that using Jailbreak Me.

If you do not have the SHSH blob on file with Cydia, you will be unable to restore to 3.1.3 though I am unsure what the failure condition for that is.

  • download 4.2.1 .ipsw from ipswdownloader.com.
  • open iTunes, it shows that your iPhone is in recovery mode.
  • press shift on your keyboard and click restore.
  • select the .ipsw file downloaded.
  • select Restore the phone will be restored and then you can re-jailbreak it.

You must log in to answer this question.