18

I have entered a weird state

Firefox was open. The icon appears in the cmd+tab task menu.

In the dock it shows as "not responding". Force Quit does nothing though.

enter image description here

Ok... but then it doesn't show in Activity Monitor either. I have searched for "Firefox", "fox", "ff", "mozilla" and skimmed through by eye.

I have also tried grepping the output of ps aux and top in terminal but I can't find it.

I wondered if maybe it wasn't really open and just the dock icon/task switcher were confused, but when I double-click Firefox from the Applications folder:

enter image description here

I have tried relaunching Finder but it doesn't fix anything.

I assume a reboot will fix it, can anyone suggest another avenue?

5

1 Answer 1

30

This is what I answered in a similar question. It did the trick for me.

I had the same problem with NetBeans and this is what worked for me:

sudo killall launchservicesd
sudo killall Dock

I hope this helps.

I based my answer in this post: Can't kill Preview app and in previous knowledge.

Check my answer here: App crashes, dock icon remains, can't reboot, yet no process in ps aux to kill.

2
  • Thanks so much, this was happening to me with Synergy app, and it happens frequently. I've now turned this into a bash script. Sep 1, 2017 at 14:59
  • While it did solve the problem of being unable to force quit the app that was not actually running (no process) but listed as running in the force quit dialogue window, it brought in a whole bag of other problems described here apple.stackexchange.com/questions/176270/… and more. So I had to reboot anyway.
    – ruslaniv
    Jan 6, 2021 at 12:21

Not the answer you're looking for? Browse other questions tagged .