1

This is specifically occurring on Yosemite Macs that have been NetRestored. Initial login works fine. However, when restarting the Mac or logging out of the user, a black screen appears with only the mouse cursor there. (Please note this is on logout, not login. I'm quite familiar with the login issue.)

I cannot even get out of it by sending a Restart (Lose Changes) command through ARD. Only a manual force shut down solves the issue.

In the past, I've removed the /Library/Preferences/com.apple.loginwindow.plist file and it's solved the issue. However, it's still occurring now. Any suggestions?

4
  • Does verbose mode give any clues?
    – Ashley
    May 26, 2015 at 18:45
  • How long did you wait? I've seen an issue that can make your computer take about two minutes to shutdown. Also, there is a slightly safer force restart by pushing command + ctrl + power button. More advisable. May 26, 2015 at 22:24
  • Sadly, verbose mode didn't really help here. And I left a Mac sitting there for 30-45 minutes. In the end, I destroyed the LoginWindow.plist and that seemed to resolve the issue.
    – ghostof101
    May 27, 2015 at 19:00
  • Used to be I could SSH in when this happened and kill loginwindow; lately that's not even working and I think I'll need to do a full restart. Driving me crazy.
    – James B
    Aug 12, 2015 at 19:22

1 Answer 1

4

Just returned here, although old question, to leave the solution I have found after long suffering this problem in High Sierra after trying to upgrade from version 10.13.5 to 10.13.6. I deleted these files through terminal, then rebooted.

You may need to enter your admin password when asked:

sudo rm -f /Library/Preferences/com.apple.loginwindow.plist
sudo rm -f /private/var/db/.AppleUpgrade
sudo rm -f /private/var/db/.SoftwareUpdateAtLogout
sudo reboot
4
  • Had the same problem after updating to macOS Mojave... This fixed the issue. Thanks Mar 5, 2019 at 21:34
  • Glad it was useful. ;-)
    – Lippoli
    Mar 10, 2019 at 23:05
  • Formatted disk, reloaded macOS, restored TimeMachine: Problem came back. Found this, deleted the files, fixed. Thanks!! There was no .AppleUpgrade file, but deleting the other two fixed it.
    – frog22man
    Jun 4, 2019 at 6:42
  • Glad it was useful also to you user83905, ...and very sorry for the almost 1 year old reply!! Found your message in old junk mail !!! :-o
    – Lippoli
    Jan 27, 2020 at 22:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .