1

I submitted the following as a Xcode bug report, but I'm post it here in case somebody is experiencing the same problem and can shed more light into the matter.

I use two devices for development: my iPhone 3GS, and a friend's iPhone 3G running 4.2.1/8C148. I could debug with both of these devices using Snow Leopard and Xcode 4.0.2.

I recently upgraded to Mac OS X Lion 10.7/11A511. I uninstalled the whole developer tools by using 'sudo /Developer/Library/uninstall-devtools –mode=all' and I installed Xcode 4.1/4B110 using the Mac App Store. I've been happily coding with my iPhone 3GS, but I won't longer work with the iPhone 3G.

When I connect the 3G, Xcode 4.1 asks for collection of the debug symbols. If I accept, it starts copying the files, but it gets stuck at roughly 80% of the process (see the attached screenshot #1 for the Organizer screen). If I look in the Activity Monitor I can see the DTDKSymbolHelper process eating up all the resources (see attached screenshot #2).

If I force kill DTDKSymbolHelper, Xcode will finish collecting the debug symbols and will believe that my 3G is ready for use. However, when I try to run my app on the 3G, the app copies successfully and it is run, but then the console shows several errors (see attached txt file), and the app gets stuck at the Default screen. The DTDKSymbolHelper process is spawned again, and it perpetually eats all the resources again.

If I exit the App via the home button and disconnect my iPhone 3G from the Mac, I can launch the app again and it runs perfectly, updated to the latest version.

If I connect my 3G to the Mac again, Xcode will ask again for collecting the debug symbols, and if I accept, it gets stuck at the same place.

I acknowledge that the most sensible thing would be to restore the phone in order to see if that fixes the problem, but I wanted to try and get to the bottom of the problem first.

In my Macbook Pro + iPhone 3GS this problem is 100 % reproducible, so please ask for any piece of information that you need.

Expected Results

Xcode 4.1 ether successfully finishes collecting device debug symbols, or it shows an appropriate error message.

Actual Results

Xcode 4.1 gets stuck indefinitely, with process DTDKSymbolHelper eating up all the system resources.

0

In case anybody is still interested, this issue changed slightly with Xcode 4.2, and I posted an updated question here: https://stackoverflow.com/questions/7922308/xcode-4-2-error-0xc002-when-trying-to-use-a-jailbroken-iphone-3g-for-developmen

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .