I started noticing this about a month ago that when I hit CMD+L or CMD+T, there is about a second or so lag to when it actually does something.

I verified it's not a memory problem, as it happens after a restart. Internet searches didn't come up with anything.

I'm using OS X 10.10.3 and Safari 8.0.6.

  • when you opening new tab, where does it go? (what is your home page)?
    – Ruskes
    May 26, 2015 at 1:59
  • @Buscar웃SD I would guess it doesn't matter because it happens with CMD+L as well.
    – abc123
    May 27, 2015 at 3:08
  • I'm experiencing this freeze this after clean install of El Capitan. It doesn't happen in "private" mode. Feb 23, 2016 at 10:28

5 Answers 5


Launch "Console" and have it running side by side with Safari. See if entries about "IMKServer" appear when the delay happens: screenshot

If you see similar entries try following below: https://gist.github.com/wkrsz/3d5ff7f908a180b87498

Steps from the article:

  1. Reboot into system restore mode (+R immediately after boot)
  2. Navigate to Utilities > Terminal
  3. Enter the command csrutil disable
  4. Reboot
  5. Open Terminal
  6. defaults write -g ApplePressAndHoldEnabled -bool false && launchctl remove $(launchctl list | grep -oE 'com.apple.PressAndHold.+$')
  7. sudo chmod 000 /System/Library/Input\ Methods/PressAndHold.app/Contents/MacOS/PressAndHold
  8. Reboot
  9. You can choose reboot back into restore mode and issue crsutil enable again to re-enable rootless mode.

It's originally from Github user squeeb: https://gist.github.com/squeeb/5a9dd082cae1b2d753a0 – I just forked the article to fix a typo in one command.

  • I enter "defaults write -g ApplePressAndHoldEnabled -bool false && launchctl remove $(launchctl list | grep -oE 'com.apple.PressAndHold.+$')" in terminal,it says "usage: grep [-abcDEFGHhIiJLlmnOoqRSsUVvwxZ] [-A num] [-B num] [-C[num]] [-e pattern] [-f file] [--binary-files=value] [--color=when] [--context[=num]] [--directories=action] [--label] [--line-buffered] [--null] [pattern] [file ...] -bash: com.apple.PressAndHold.+$: command not found Usage: launchctl remove <service-name>".I'm using 10.11.3
    – quxinna
    Mar 20, 2016 at 17:24
  • @cuthead what's your output for launchctl list | grep PressAndHold? Mar 21, 2016 at 10:04
  • my output is nothing,in fact I use baidu wubi input method mac and this problem solved.I think this problem relate to OS X Chinese input method.
    – quxinna
    Mar 22, 2016 at 2:14
  • SCIM[536]: IMKServer Stall detected, please Report your user scenario attaching a spindump (or sysdiagnose) that captures the problem - (sessionFinished) block performed very slowly (2.95 secs) here is my console output
    – quxinna
    Mar 22, 2016 at 13:19
  • Both of your links are dead.
    – Sparky
    Jan 27, 2021 at 17:03

There are a few things you can try:

  • Turn off iCloud sync for Safari
  • Set "New tabs open with:" to "Empty Page"
  • But for me, the culprit was "Retab" Safari extension.
  • Set "New tabs open with:" to "Empty Page" fixed it for me.
    – magiconair
    Aug 27, 2015 at 8:03
  • I'm experiencing the delay with "New tabs open with:" set to "Empty page", or "Favorites", both of which focus address bar and show suggestions. The delay disappears when I change the option to some home page or "about: blank", which do not focus address bar. But then I have to hit CMD-L to type address, and - lo and behold - we have the delay again. Feb 23, 2016 at 9:48
  • Tried all above, removed all favorites and read items, disabled plugins and everything I could possibly disable in preferences - no effect. Feb 23, 2016 at 11:11

Disable "Include search engine suggestions", Open New Tab (⌘T) is fast again...

enter image description here


This is a test, not a fix.

Open Terminal and type "nettop"

Scroll down (with arrow keys) till you see Safari.

Now scale the Safari and Terminal window side by side.

In Safari do the cmd+t and immediately switch/watch the terminal window for new connection. It should show established with in micro seconds.

  • I will try this when it starts happening again, thanks.
    – abc123
    May 27, 2015 at 3:07
  • I noticed the CMD+L with a delay just now. But on subsequent tries, it was fast. Not sure if that helps at all.
    – abc123
    May 29, 2015 at 20:05
  • that variation does indicates a network speed variation. we need to catch it in the act :) Just try changing the default window (home) to Google.com and use the cmd+t again. Also just to test, turn off the Extension (if any) in the Safari.
    – Ruskes
    May 29, 2015 at 20:12

enter image description hereThis happened to me. And this fixed it for me.

Preferences -> Search -> uncheck "Show Favorites".

  • To my surprise this worked for me, unchecking only 'Show Favourites' but leaving the other smart search options enabled significantly reduced lag between selecting & typing in the search bar. (Safari 14.1 on Big Sur)
    – Rob Farr
    Jun 8, 2021 at 20:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .