2

I recently purchased my first rMBP and I have noticed that Mail receives emails extremely slow. I receive the email on my iPhone 10 - 15 minutes before it appears on Mail.

I've tried searching for solutions however it doesn't seem like this is a problem many are having. Anyone have any solutions?

  • the iPhone's email populates by "push" which means as soon as the server gets it, you will be notified. The Mac's email is "pulled" at a timed interval as Buscar웃SD mentions below... – scoutelder May 26 '15 at 2:18
2

In Mail there is a Activity view. Turn it on and see what is happening.

It looks like this

activity

All the bars should disappear with in a 1-2 minutes.

Also check in the Mail preferences the setting for how frequently to check for Mail. Hope it is not set on 15 minutes but more frequently.

get mail

0

Make sure the IDLE command is selected in Mail > Preferences > Accounts > Account in question > Advanced", if supported by your server.
It's not the same as 'Push', but can speed up Mail delivery.

enter image description here

0

Consider clearing or archiving folders where mail is automatically being placed.

After trying many things (like clobbering old directories in Caches, Preferences and Containers) with only minimal benefit, I had some success by clearing out some subfolders that I don't pay much attention to, where I have less-important mail refiled by server-side rules.

When those folders had around 10K messages in them, I saw mail get stuck "Downloading messages" forever, not pull in incoming Mail for hours (until restart), or simply crash occasionally. I haven't seen any of those since clearing out that clutter, knock on wood.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .