Why does Messages.app on my Mac (Yosemite) fail to play a sound when a message is received?

On my Mac, I'm hearing sound from other apps. I hear a sound when I drag the "Output volume" in System Preferences > Sound > Output.

I hear the ding sound when messages simultaneously arrive on my iPhone and iPad.

In Messages > Preferences > General > Message received sound I have the popup set to "Note (Default)". Changing that popup does not help.

In System Preferences > Notifications > Messages > Play sound for notifications is checked. Unchecking and rechecking does not help.

The only odd thing, the only clue, is that in System Preferences > Notifications > Messages I found the Messages alert style icons had "None" selected but nonetheless have been seeing the Alerts style notifications appear upon new messages. Perhaps there is some kind of settings file not being updated, and needs to be trashed?

  • try a simple task first, use disk utility and repair permissions. try with logging in as different user to see if your user profile needs fixing.
    – Ruskes
    Commented May 25, 2015 at 21:00
  • What happens if your phone and iPad are off? My MacBook doesn't "ding" if my phone gets the message first.
    – miken32
    Commented May 26, 2015 at 3:47
  • Did you ever find a resolution to this?
    – Justin
    Commented Apr 21, 2016 at 19:26

3 Answers 3


I had the same problem and I found that in System Preferences> Sound> Sound Effects: The "Alert volume" was set at zero. Adjusting it up solved my problem.


I had the same problem, I think I found what it was, for me at least.

System Preferences -> Sound Effects -> Play sound effects through: Internal Speakers


My issue was a software program that somehow became my default sound program. I changed it back to internal speakers, and all is well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .