0

I run OS X Yosemite (10.10.3). From the sysadmin account, I created a standard account. This account can't open standard directories like Documents or Pictures in the admin’s user folder. It can access however every single folder and document that does not belong to this preinstalled standard folders. Changing folder permissions in the admin account does not change anything. What am I doing wrong?

  • Note that Documents etc. has + sign when you ls -la ~. Check out ACL (Access Control Lists). – Mateusz Szlosek May 25 '15 at 18:17
3

The simplest way to prevent the access is by Get Info.. (or +i on directory and setting the permissions there.

To prevent other user from viewing your files, settings should look like:

  • username(me) read / write
  • everyone no access

Note: remove all the other positions like group etc.

  • As I wrote "Changing folder permissions in the admin account does not change anything." – lejonet May 25 '15 at 20:00
  • 1
    Note: You need to remove "staff" and leave only "me" and "everyone", set "everyone" to no access. – Mateusz Szlosek May 25 '15 at 20:38
  • I can't remove "staff", it tells me I have no right to do so although I am an admin. – lejonet Jun 22 '15 at 18:56
  • 1
    @lejonet click on the padlock in the lower right corner, You'll be asked for Your admin password. – Mateusz Szlosek Jun 22 '15 at 19:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .