7

I'm using VMware Fusion 7.1.1 to run both Windows 8.1 and Windows 10 on a mid 2014 15-inch retina Mac. I've heard it is possible to run VMware in such a way that the screen's native resolution (in my case, 2880x1800) is displayed without any scaling.

After lots of trial and error, I discovered this works fine using the default desktop scaling in OSX. However, I normally run OSX in a scaled display setting (the default scaling makes everything too big to my tastes), where it actually renders everything at 3360x2100 and then downscales that to 2880x1800. It seems this also happens when using VMware Fusion, which means the perfect 2880x1800 picture from Windows gets stretched to 3360x2100, only to get scaled down to 2880x1800 again, leaving me with edges and text being blurrier than they should be.

Is there any way to prevent this from happening? I'd rather not change back to default desktop scaling in OSX every time I want to use VMware Fusion.

5

From here:

  • Install the VMware Tools by selecting Virtual Machine → Install VMware Tools in the menubar. Follow the on-screen instructions.
  • Set Use full resolution for Retina display in VMware Fusion’s Settings → Display preferences panel.
  • Run this command in Terminal on your OS X guest VM and enter your password when requested: sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true
  • Log out of your OS X guest VM and then re-login.
  • Resize your OS X guest VM window to your preferred dimensions.
  • In System Preferences → Displays, set the resolution to Scaled and then select the HiDPI setting.

Note: If you resize your guest VM, it will revert to the non-HiDPI resolution. Simply re-select the HiDPI resolution in the System Preferences → Displays preferences panel.

  • 1
    I'm specifically trying to run Windows, so there is no OS X guest VM. – Bram Speeckaert Jun 16 '16 at 15:41
4

Look under settings for the Virtual machine and under the display settings should be a check box

Use full resolution for retina display

Uncheck it.

  • Unfortunately, this doesn't do what I'm looking for. Now it seems to be downscaling the 2880x1800 picture to a lower resolution first, which is then upscaled again. – Bram Speeckaert May 26 '15 at 12:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .