For years I've zoomed the whole Mac OS X screen with Control ⌃ + two finger scroll on the trackpad.

It was very useful when giving demos and when wanting to zoom in on a YouTube video.

Since I installed Lion it was working, then it stopped working, then worked again, now it's not working.

What am I doing wrong, or is it just broken?

  • 1
    I just found that it's when the mac wakes from sleep this feature breaks, as does all zoom behaviour. Restarting is required to fix.
    – Brett Ryan
    Commented Aug 5, 2011 at 13:08
  • Found that resetting SMC helped support.apple.com/kb/ht3964, also NVRAM/PRAM reset may be required also: support.apple.com/kb/ht1379
    – Brett Ryan
    Commented Aug 6, 2011 at 14:34
  • Even after resetting SMC, this keeps rearing its head on me, seems this must be a bug in Lion as I get it on several macs. I have a suspicion that it could possibly be boot-camp related.
    – Brett Ryan
    Commented Sep 5, 2011 at 11:29
  • I've got various similar desktop related issues (not being able to change desktop, invisible previews in Mission Control) in Mac OSX Lion from time to time. Killing the process "Dock" usually helps. Use the Activity Monitor, or the terminal: killall Dock.
    – Joel Purra
    Commented Dec 25, 2012 at 21:47

10 Answers 10


I had this problem with Leopard and it continues in Lion. The only solution that works for me is to reboot. Changing the settings in system preferences does not work on my machine.


You now have to manually enable it.

  1. Go to Universal Access in System Preferences
  2. Turn on Zoom with the radio button.
  3. Click on Options and tick Use scroll wheel with modifier keys to zoom.
  • 1
    Just FYI, I had to reboot to get it working again. Pretty sure it broke at some point over the past few days. I'll keep an eye on it and see if it "breaks" again. Commented Jul 26, 2011 at 21:24
  • I have this set, however whenever I turn zoom "ON" it goes into a fixed area that doesn't move with mouse, I do have that option turned on also. I am starting to think that the zoom feature is somewhat broken in Lion.
    – Brett Ryan
    Commented Aug 5, 2011 at 11:46
  • I tried to capture the zoom behaviour with QuickTime, but it doesn't show the screen zooming, however I've got the right settings and all zoning seems a little broken for me. youtube.com/…
    – Brett Ryan
    Commented Aug 5, 2011 at 12:02
  • Okay, just logged into a new account on my computer and the old behaviour does work, but it seems to have become broken on my main account. FYI, you don't need to go to accessibility to enable this feature, you can go to "Preferences > Mouse" and tick "Zoom using scroll ball while holding ...", you do not need the accessibility zoom feature turned on for this to work.
    – Brett Ryan
    Commented Aug 5, 2011 at 12:05
  • Robert, I applied your recommendation of a reboot, and it's working. FYI I have "Zoom" in accessibility turned off still and it's working fine now :)
    – Brett Ryan
    Commented Aug 5, 2011 at 12:11

I experienced a similar problem in the Developer Previews of Lion. A restart always fixed it.

I've not had any problems since I installed the GM public release build.

If you are experiencing such problems I suggest sharing feedback, and filing a bug report.

http://www.apple.com/feedback/ https://bugreport.apple.com/

  • I tried to log in, got this: "An error has occurred. Please report the error to Apple Inc. by emailing the error detail to [email protected].". Hmm... Commented Aug 22, 2011 at 6:39
  • nevermind, a restart fixed it. Commented Aug 24, 2011 at 2:09

Several answers contradict each other, so I wanted to make another answer to pull together some of the ideas that seem (to me) to be the root behavior of zoom failures:

  1. The zoom feature that many used reliably in Snow Leopard breaks often in Lion. It generally works perfectly immediately after a reboot. A quick sleep / wake cycle after a reboot isn't the only thing needed to break this, but it appears to fail after longer periods of sleep.

  2. When migrating from Snow Leopard to Lion - the migration is breaking the settings for people that had the zoom enabled. By "break" - the panel shows zoom off (or greyed out) even if it was previously on for Snow Leopard. Strangely, the system will zoom when the panel shows zoom off in this case of a migration.

enter image description here

Once zoom is "broken" a reboot will make it work again temporarily - it recovers from the failure, but doesn't prevent it from recurring again. The new zoom in window feature seems to work reliably - the window zooming will work when normal zooming is broken - you can turn that on to nudge the zooming without a reboot.

All of the above are "facts" that I've seen and reproduced on more than one Mac as well as seen more than one time on each mac that has had the problem.

My speculation is the new window zoom features (which are amazingly cool) is causing the tried and true older zoom function to have problems as the machine runs and some process crashes or some memory gets corrupted. Switching to Zoom in window or rebooting clears up this corruption or restarts whatever process needs serves the zooming temporarily.

My primary mac seems to fail to zoom somewhere between 8 hours into a boot and almost certainly after a day or two of use. I haven't tested a log out / log in to clear things up (yet) - but it's a near certainty it will be back within 48 hours for me to poke at it some more and see if I can see what is crashing...

There may be a link between using the default Control ^ key as the zoom modifier - the preference pane for choosing that modifier seems "screwy" to me in that it will substitute values for control when I go to look at the pane. I haven't determined if my preference file is corrupt or the system code is just mis-behaving whether or not the preference file is correct or not.


From support.apple.com:

The OS X Lion v10.7.2 Update includes […] fixes that: […]

  • Resolve an issue that causes screen zoom to stop working.

So the answer and the solution is, in short: update to 10.7.2, if possible.


I adjusted the size of the "zoom in window" to cover the entire screen real estate; works as an adequate substitute for the big fail on screen zoom.


My zoom, for some reason, breaks when Lion goes to sleep. To fix it I just go to universal access turn zoom off, and then back on. When its is broken the radio is on but the stuff beside it is greyed out.


It is still broken for me in the 10.7.2, it does work very erratically…

My workarounds are to:

  • Use + or - (instead or ctrl scroll) (Press 8 two times to reenable the zoom if the key above are not working)
  • Trash ~/Library/Preferences/com.apple.universalaccess , open Universal Access and switch the zoom option to "ON". This seems to be the best workaround to make everything work again (including the ctrl+scroll).

I have found a solution. In Universal Access > Seeing Tab -- select Zoom in window as usual. Then, select Options > Use scroll wheel with modifier keys to zoom. If you have Enable temporary zoom... and the scroll wheel options selected... if you 'scroll out' on your mouse the zoom window will disappear once zoomed all the way out. Then, when you need it, hold command in scroll in with the wheel.


This resolved the problem in my case

Go to System Preferences -> Energy Saver

and check off

"Automatically reduce brightness before display goes to sleep"

If that doesn't work, this other solution temporary fixes the problem (so you don't have to reboot):

System Preferences -> Universal Access and re-check "Zoom in Window"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .