43

I noticed that the new Photos.app reduces image size on export. If I drag & drop a photo from the Photos library, the size is reduced by at least 50%.

How do I get rid of this behavior and recover my original photo file?

35

File > Export > Export Unmodified Original...

enter image description here

will export a full size image to the folder of your choice.

| improve this answer | |
  • 2
    You need to select all the pictures first, otherwise, the option is greyed out. – kenorb Jul 29 '18 at 17:20
24

I found the original in:

~/Pictures/Photos Library.photoslibrary/Masters/

I still need to find a way to tweak the awful default behavior...

| improve this answer | |
  • Did you ever find a way to modify the default behavior? It's such a nuisance to have to use that menu option every time I want a single photo out of the Photos app. – jsejcksn Jan 5 '16 at 23:13
  • Did the .../Masters/ folder contain all the originals imported to the Photos App? I started using Photos to collect all photos together, then changed my mind - can I get them all back out quickly this way? – qxotk Dec 19 '16 at 21:40
  • I just inspected the app contents for the photo app, and found my Masters/ folder, and I see that it has used the filesystem like a database, so the files are spread across folders broken up by year, month, day, etc. Would make a good first app to create retrieve a copy of all the master copies out of the Photos app database. – qxotk Dec 19 '16 at 22:50
  • 1
    A simple shell command would do;) – Antzi Dec 20 '16 at 0:07
  • 1
    Masters has a structured file system organized by dates which I like. But if you want only photos, you can simply do the Smart Search... type "kind: image" in search from Masters folder and it will display all images within Masters. It will take a while for it to display all of them and you can then drag them to a different location. – netrox Jun 19 '17 at 19:39
18

The title of your question asks how to export photos in full quality, whereas your last sentence asks how to recover your original photo. @JaimeSantaCruz is absolutely correct that you can Export Unmodified Original, which will give you a full-quality copy of your original. However, if you've made edits to the photo, they will be lost with that command.

What I would suggest is using the standard Export command instead (⇧ shift ⌘ cmd E).

File→Export

If you expand the Photos section by clicking the button you will be given the choice of several parameters for your export.

Photo Export Options

Make sure you pick Full Size as the Size.

For JPEG Quality, I recommend High for photos taken with an iPhone or iPad, as I believe this is the quality setting used by iOS to save photos.

As a test, I emailed an iPhone photo to myself as Actual Size, from my iPhone then from macOS Photos (using the Share action), and also exported it using Unmodified Original, High and Maximum.

Unmodified Original, High and email as Actual Size from both iPhone and macOS all came out to the same size (although emailing from macOS occasionally produced a slightly larger file). On the other hand, Maximum produced a file almost three times as large, with no perceivable difference in quality when blown up on a 27” non-Retina iMac.

Therefore, I would only use Maximum for images imported manually, known to use a lesser compression (higher quality) originally.

Note that when you Export an edited photo, Photos re-encodes that photo (necessary to apply the changes). That is why the size of the exported photo won’t match the original. Using Export with High quality on an unmodified photo should produce the same photo as Unmodified Original.

Personally, when I drag an iPhone photo from Photos to my desktop, it is exported with the same size and quality as an Unmodified Original or a photo shared by email as Actual Size. As far as I can tell, this is not a case of Photos simply applying your last-used settings. So I'm not sure why you're seeing different behavior.

It’s also worth mentioning that you’ll get to choose compression options when you export videos as well. However the videos appear to be re-encoded regardless of the settings you choose for Export. They do not get re-encoded when you use Export Unmodified Original.

| improve this answer | |
  • Mr Phong - I wouldn't be sure of that. When I export from Pictures App to the file, I use High Quality JPEG File and Full Size. After that I checked the size of exported library - it was 1 GB (about 500 pictures), but in fact on iCloud Library and in Pictures it takes 2 GB of storage. I compare one picture - it took about 2 mb in Pictures App and 1,6 mb on HDD disk space after exporting. So my guess is I lost some quality? Did I lose geo-tags too ? – user155075 Oct 30 '15 at 15:08
  • 1
    I’ve noticed discrepancies on certain photos as well, but that is expected since you are recompressing them when Exporting. Maximum is uncompressed, or close, and is always a lot bigger than what my iPhone takes. Admittedly, that’s a small sample size. As for exporting geotags, that’s an app-wide setting under Photos —> Preferences. – user11633 Oct 30 '15 at 18:38
  • 2
    @Phong, well thought out and accurate answer. More detailed than the selected answer. – GrowlTiger Oct 14 '16 at 21:18
10

As an alternative to the solutions described in the other answers, you may drag-and-drop from Photos to, e.g., the Finder by holding the alt key. Doing so will cause the original to be copied instead of the converted version. This works both for photos and videos.

| improve this answer | |
  • This does not work for me in Photos.app v1.3 on OS X v10.11.2. – jsejcksn Jan 5 '16 at 23:28
  • 4
    works for Photos 1.3 in OSX 10.11.3 – setempler Mar 26 '16 at 22:37
  • As far as I can tell, in Photos 5.0 holding the Alt key makes no difference -- instead, when photos are dragged into the Finder, their originals (or high-res copies) are copied, but when photos are dragged into other apps, smaller-resolution copies are copied. Particularly annoying is that mp4 movies seem to be copied as jpeg images. – Neal Young Aug 23 at 22:22
-3

right click and select displayn package content should do enable that.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .