I have a lot of NTFS hard drives back when I used a Windows PC. I'm trying to write to these drives with my Macbook Pro on OSX Yosemite 10.10.2. I'm going through this tutorial. I have to write this line in /etc/fstab

LABEL=drivename none ntfs rw,auto,nobrowse

The caveat is that "drivename" must not contain spaces. My drives have spaces. For example, one is named "HGST Deskstar". Also, another shows up as "Untitled" (it's probably not literally named Untitled). I couldn't figure out how to rename my drives to conform to the standard. What should I do?

I know there's software that you can install to handle this, but I was hoping to just do this quick system configuration.

3 Answers 3


You can use the UUID instead of the volume label however a word of warning about using the built-in NTFS Write capability of OS X... It's not stable and I'd highly recommend using a third party utility. I use the paid version of Tuxera NTFS for Mac and enable/disable as needed. IMO it's faster and more safe then the built-in.


UUID=4485D2B9-C375-5240-8F5A-2225B24332EB none ntfs rw,auto,nobrowse

You can get the Universal Unique Identifier of the Partition from Get Info in Disk Utility. Select the target partition then either click the Info icon on the Toolbar, press Command-I or click File > Get Info.

  • What do you mean by "not stable"? Will the entire drive become corrupted or just files that I'm writing? Also where's the UUID in the Disk Utility? I see a lot of ID's like USB Serial Number and Disk Identifier, but they're not formatted like the example UUID that you provided.
    – JoJo
    May 24, 2015 at 6:10
  • There is always the potential for corruption when writing to an NTFS volume under OS X regardless of how write support is implemented and why I only enable it when I have to. The reason I said not stable is because if it was then Apple would have made NTFS Write support transparent not having to modify fstab or use third-party resources. The bottom line is all NTFS Write support under OS X has issues depending on version of OS X and version of third-party resources and one should maintain proper backups when enabling NTFS Write support, which one should do anyway. May 24, 2015 at 9:40

You should replace the spaces with the escape sequence ‘\040’. Then it works fine. For example:

LABEL=My\040External\040Drive none ntfs rw,auto,nobrowse

On El Capitan it is not possible to get an UUID for an NTFS drive and even mounting the USB drive with RW options will still make the drive in Read Only mode.

I have used a solution from this link which helped in my case:

Write to NTFS-formated drives on Yosemite

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .