0

I have a severe permissions' issue. I hope there are some really clever people out there, who might know how to solve this using the Terminal, expert-level hacking or in some really simple way so I at least can backup my data despite the faulty permissions.

This is the cause of the issue

Being a curious person, in Finder I right-clicked my User and hard-drive unit and removed "staff" as well as changed permissions for "everyone" under permissions. After this my Mac (Macbook Pro, 13 ", early 2013, latest version of Yosemite) hung and every time I try to start it up, it gets stuck loading before the login screen.

This is what I have tried and all have failed

  1. Booting the faulty computer and letting it be to see if it would finish loading.

  2. Rebooting it with cmd+r, entering disk utility, repairing permissions. This outputs

    User differs on private/var/db/displaypolicyd; should be 0; user is 244.
    Group differs on private/var/db/displaypolicyd; should be 0; user is 244.
    Repaired "private/var/db/displaypolicyd"
    

    However, when I reboot the permissions' issue remain and when entering Disk Utility again, I get the same permissions' repair messages.

  3. Rebooting it and creating a new ACL.

  4. Using another Macbook Pro, mounting the faulty one with the help of rebooting it in Target Mode. However, the permissions' issue doesn't permit me to access the drive this way. In Disk Utility, I can select the drive with the faulty permissions, but I can't select the option repair permissions.

  5. Using another Macbook Pro, mounting the faulty one with the help of rebooting it in Target Mode and creating a new image (dmg) of its hard-drive to the functional computer.

  6. Looked at the answers in How Should I Correct the Owners and Permissions in an OS X User Folder?, but they don't help in solving my problem

This I need help with

  • How can I repair the permissions considering this specific case and what has been tried already?
  • Or (if there is no easy way out of this) is it possible to make a backup of the drive so I can reinstall everything without loosing data?
1

To get started, you need at least to re-install the OS. Boot into the recovery system by pressing Cmd-R on system startup and the proceed with installing the OS. This will (unless something goes very wrong) not impact your existing data

After that, you will at least have a system which boots again. What still needs to be done (and which may turn out to be a rather cumbersome process) is to fix permissions for all non-standard applications and their support/library files. Again, just reinstalling these applications might be the easiest way.

  • Maybe a manual chown -R root:wheel /private/var/db/displaypolicyd in Single User Mode would suffice? – Max Ried Nov 7 '15 at 10:18
  • Or maybe a chmod -R 777 /private/var/db/displaypolicyd as a quick fix? – Max Ried Nov 7 '15 at 10:19
  • I just had a look: drwxr-xr-x 2 244 244 68 Sep 17 03:04 /private/var/db/displaypolicyd... So it's just correct as @MissTricia has it on her hard drive... – Max Ried Nov 7 '15 at 10:24
  • displaypolicyd is not the problem. According to the question the OP changed the permissions on the whole HD. – nohillside Nov 7 '15 at 11:11
  • Yes, but the only hint we have is this folder. – Max Ried Nov 7 '15 at 11:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .