10

Every time I take a screenshot, I get this error:

You don't have permission to save files in the location where screen shots are stored.

How do I fix it?

  • 1
    Most probably by fixing the ppermissions of your Desktop. Could you please run the following commands: cd ~/Desktop ; ls -ld . ; touch test? – daniel Azuelos May 22 '15 at 13:23
  • 2
    No-one asked yet where the save location is... – Tetsujin May 22 '15 at 16:49
  • This needs more information to answer conclusively. I've added a triage step answer, feel free for someone to ask a new question with that detail and perhaps the version/build of OS X they have this issue on... – bmike Dec 30 '15 at 15:27
  • In my case I had deleted the Desktop folder - setting it to somewhere else per apple.stackexchange.com/a/221559/136365 worked – Ben Creasy Aug 1 '17 at 22:37
10

If you type defaults read com.apple.screencapture location into a Terminal window it should tell you where OSX is currently trying to save screenshots.

You can change the location with a similar command. For example:

defaults write com.apple.screencapture location ~/Desktop will save screenshots to your Desktop.

defaults write com.apple.screencapture location ~/Documents will save screenshots to your Documents folder.

Once you've told it a new location you need to run the following command for OSX to pick up the change.

killall SystemUIServer

  • 1
    I have a brand-new macOS machine and straight out of the box, this was not set - The domain/default pair of (com.apple.screencapture, location) does not exist Apple Care told me to reboot, etc., etc. and other things that weren't useful so it didn't sound like they knew what I was talking about. Does anyone know if this is broken or is this not supported by default on macOS (I'm running Sierra)? – harperville Jan 17 '17 at 0:45
  • I'm curious how my machine lost this setting. It was working yesterday, but not today. This solution fixed my problem, but I suspect Parallels did something to my machine yesterday when I ran it because lots of settings seems to have magically changed since then. – nedlud Aug 9 '18 at 3:46
1

Run disk utility and select your hard drive, then repair permissions. While you can do this with apps running it would probably run more smoothly and quickly if you quit out of all open apps before doing this.

If repair permissions fails for whatever reason start the Mac in recovery mode (COMMAND-R upon reboot) and then go into disk utility and repair the disk and then permissions.

If it still fails it may be time for a 3rd-party disk repair utility.

  • Does repair permissions touch the desktop folder? I thought it only checked permissions where software is installed? – Alistair McMillan Nov 27 '16 at 17:02
  • As far as I know repair permissions checks permissions on much more than applications, including system and user folders. – Steve Chambers Nov 27 '16 at 17:23
  • This suggests it only checks files and folders associated with pkg installers. support.apple.com/en-gb/HT201560 – Alistair McMillan Nov 27 '16 at 17:31
0

Another case where this error will occur is if the connection to a network-based home folder is broken. A bunch of other trouble will occur simultaneously, but if you try to take a screen shot of that trouble, you'll get this error message. (From first-hand experience)

Doubt that this is the answer to the original question; but it's probably worth noting nonetheless.

0

Make a new user and see if the problem is due to errors on your account would be my first step.

Once you know it's a system problem or a user problem you can proceed as the fix is different for both. I would start a new thread with this detail added since there are going to be two cases to solve for the general situation causing this error.

You could also use the Grab app to save the screen shot to a place you do have permissions and avoid the system screen shot problem entirely.

-1

Go to the location, right click and select Get Info, then uncheck "Locked"

You must log in to answer this question.

protected by Community Dec 30 '15 at 15:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .