The Photos app opens whenever I plug in my phone.

How can this be prevented?

I have seen many solutions for the old iPhoto app that involve changing the "Connecting camera opens" option, but the new app has no such option.

up vote 35 down vote accepted

With the iPhone plugged in, open the Image Capture app on your Mac. In the Image Capture window, left lower corner, choose which app should automatically open when you plug in your phone, chose "no application"

Image Capture screenshot instructions

  • Note, this solution also works if you don't use photos app, and can't go to the import screen to make the change as @terrydev suggested. – otmezger Sep 8 '15 at 14:05

If you like the command line or need to have all devices not open rather than manage each single device as it connects and then after Photos has already opened, try:

defaults -currentHost write com.apple.ImageCapture disableHotPlug -bool YES

This sets a flag to tell the system to not activate ImageCapture or Photos or iPhoto when a hot plug of an iOS device is detected.

  • 5
    This unfortunately no longer works as of 10.11 "El Capitan" – Nicholas H. Nov 5 '15 at 13:41
  • 3
    @NicholasH. If you change the syntax slightly (adding -currentHost) to the defaults command it works on El Capitan. You can see the edit history if you're curious what command used to work and how the current command differs from the answer before Nov 2015. – bmike Mar 3 '16 at 16:30

Plug in your phone and let Photos load. Then note check box in the Photos window and uncheck it:

Photos sceenshot

  • 1
    My "Open Photos for this device" box was already unchecked and the Photos app was still popping up each time I plugged in my phone. However, I checked and then unchecked the box and presto.... no more Photos app auto-launching. – user134226 Jun 30 '15 at 16:46

Just launch iPhoto, it's still in your Applications folder (if not try the Purchases tab in the Mac App Store app). The same old "Connecting camera opens" option is still there and still works.

protected by Community Oct 26 '15 at 1:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.