10

I am an eager Terminal user on Mac OSX Yosemite. From time to time I mark text in the Terminal window to copy(right click or cmd+c) onto the clipboard.

For some reason it suddenly stopped working! I can not mark text in the terminal window anymore by clicking and dragging the mouse. I have been looking for a way to turn marking off an on(on Windows Command line tool there is such a setting for some reason), but I cannot find any option for controlling this. Even though it is not possible to mark with the mouse, I can select "Edit"-"Mark everything"(freely translated from the Norwegian OSX version :)) from the file menubar at the top of the screen - and mark everything works fine. I can see everything marked and I can copy and paste as expected. There is however no way I can affect the marking with the mouse - after marking everything it cant be unselected with the mouse.

Does anyone have any tips for how to enable marking with clicking and dragging the mouse again?

  • What if you use another profile? See Preferences -> Profiles. – Pepijn van Leeuwen May 21 '15 at 17:27
  • Using different profiles didn't work unfortunately. I had to use @kylebellamy 's solution below. – Markus Bekken May 22 '15 at 9:18
7

Sometimes things go wonky in the preferences files and you need to delete them to get things working properly again. Once you restart the app, it will rebuild it's preferences.

Try this:

Quit Terminal completely and then delete this file: (your home folder)/Library/Preferences/com.apple.Terminal.plist

Hopefully that works for you! If you can't see your library folder, follow this quick guide.

  • It worked! I quit the Terminals, but instead of deleting I renamed the .plist file for terminal. On next startup it worked perfectly again :) – Markus Bekken May 22 '15 at 9:18
  • Great! That tends to be a great step for an application that is acting strangely. – kylebellamy May 22 '15 at 12:55
3

It's possible that mouse events are captured by the program running in the terminal. For that to happen:

1) The program must be written to support mouse (vim and tmux are both examples of such programs), and

2) Terminal must be in Mouse Reporting mode. This mode is enabled by default.

If you disable Mouse Reporting (View/Allow Mouse Reporting, ⌘R), mouse events will not be captured regardless of whether the application supports mouse or not, and you will be able to select and copy text.

  • ⌘R was the trick to allow copy/paste with Midnight Commander in Terminal. – mivk Sep 4 '18 at 10:48
2

I had this problem and solved it just by quitting the terminal completely and opening it again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .