0

I need to access my computer running nginx on port 8080, but I do not want to turn off the firewall. I know that I can allow application to connect, but I can not figure this out with nginx.

The binary is added to the "Firewall Options..." from /usr/local/Cellar/nginx/1.8.0/bin/nginx

I have also tried creating a code-signing certificate, but no luck.

3

I’m assuming this is nginx running on a Mac, but you’re not providing much details.

  1. Quit the nginx process
  2. Go to System Preferences: Security: Firewall: Firewall options, and remove nginx or anything else that is denied
  3. Restart the nginx process

A dialog will appear asking you to grant the nginx process access to listen for incoming connections. You may need to configure port forwarding on your router as well.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .