3

Months ago I performed a clean install of Yosemite, and as you can read elsewhere, drive was formatted as Core Storage. Later on I partitioned and put on Windows 8.1 through Bootcamp.

Worked well for months (still working actually). I was booting holding the option key and I was able to choose between the OS X and Windows partitions.

However, Bootcamp does not provide drivers to read Core Storage disks. So, in order to get read access to the OS X drive from Windows, I followed the most common suggestion I could find: diskutil coreStorage revert <UUID>. It is well (though unofficially) documented and worked with me also - OS X drive is HFS+ again and I can read it when booted into Windows.

So?

The only issue I could find is that now, when booting holding option, I am presented a third option called EFI boot. I am not brave enough to click on it, but would like to know what is it, why it's there and eventually how I can get rid of it. It is not shown in Disk Utility of course.

Here is an image pretty similar to my case:

enter image description here

Before doing diskutil coreStorage revert I had just Yosemite and Windows options; now there's this new guy. However this happens only in the boot screen; there's no EFI boot in Disk Utility nor in the Startup Disk view.

diskutil list

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *750.2 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            609.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data Windows HD              140.0 GB   disk0s4
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:        CD_partition_scheme                        *116.8 MB   disk1
   1:     Apple_partition_scheme                         101.7 MB   disk1s0
   2:        Apple_partition_map                         17.9 KB    disk1s0s1
   3:                  Apple_HFS Vodafone Mobile Broa... 31.9 MB    disk1s0s2

//last one should be my internet key actually plugged in.
  • A have a few more questions. First, what icons appear when you go to the "Startup Disk" window under the System Preferences application? Second, could you post to your question the output from the command diskutil list? Third, what is the model of your Mac? – David Anderson May 21 '15 at 15:34
  • @David (1) I see no EFI stuff there, just OS X and Windows. (2) Updated answer with the output, and (3) MBP 15" early 2011. Thank you. – natario May 21 '15 at 15:43
  • How can you say "I see no EFI stuff there" as it's disk0s1 as it's supposed to be. It's just not supposed to on the boot menu. You'll need to look for a way of hiding it on the boot menu however you should not remove it from disk0. – user3439894 May 21 '15 at 15:52
  • @user3439894 there was referring to David first question - in System Preferences -> Startup Disk. I definitely see EFI stuff in diskutil list, though I don't know what it is. – natario May 21 '15 at 15:55
  • Since you have reverted again from CoreStorage, the Recovery Partition is visible again in the boot manager, you show in the screenshot. It has been misnamed (I have seen it myself), but if you boot into it you should recognise the Recovery HD. At the time I renamed mine via the bless command. – Redarm May 21 '15 at 16:03
4

To rename the Recovery Partition, falsely named "EFI Boot", I first mounted the Recovery HD, by showing all partitions in Disk Utility. To show all partitions:
1.) quit Disk Utility
2.) In Terminal write or paste:
defaults write com.apple.DiskUtility DUShowEveryPartition 1 and hit 'enter'.
Launch Disk Utility and mount the hidden, but now showing "Recovery HD" by selecting it in the sidebar and clicking the "mount" menu. Here it did mount with its proper name "Recovery HD".

Then rename it by using Terminal and this command:
sudo bless --folder /Volumes/Recovery\ HD --label "Recovery HD", or change the label "Recovery HD" to something that's preferred.

To revert Disk Utility's 'show all partitions' just use the same command with '0' instead of '1': defaults write com.apple.DiskUtility DUShowEveryPartition 0

Edit: changes in macOS Sierra lead to a different approach:

  1. Find the disk identifier by running the following command in Terminal:

    diskutil list

This will identify the Recovery HD with diskXsX (e.g. disk0s3)

  1. Mount the Recovery HD with the help of its found identifier, e.g.:

    diskutil mount disk0s3

as in the example mentioned above in step 1, replacing "disk0s3" with your own found identifier.

  1. Then use the following command for the disk label to change:

    sudo bless --folder /Volumes/Recovery\ HD/System/Library/CoreServices --label "Recovery HD"

Again, replacing "Recovery HD" for your own preferred disk label.

  • Did it! I have two questions. How can I get back to the original Disk Utility? I have tried default delete com.apple.DiskUtility DUDebugMenuEnabled, and the Debug menu is gone, but I can still see the hidden un-mounted disks. – natario May 22 '15 at 6:57
  • And second: is this labeling related to OS X only? I would like to also relabel the Windows partition, because I don't like it's name at option-boot. Can I do this, or would Windows OS get angry when booting into it? – natario May 22 '15 at 6:59
  • Ok for the first, I just had to deselect "Show every partition" in the debug menu. – natario May 22 '15 at 7:06
  • It should theoretically also work for Windows, but I can't test. – Redarm May 22 '15 at 10:45
  • Yes, the Debug Menu is not really needed and you could enable and disable "Show every partition" separately.<br> defaults write com.apple.DiskUtility DUShowEveryPartition 0 would have disabled it again without the Debug Menu. – Redarm May 22 '15 at 11:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .