1

The iCloud calendars in my iOS Calendar app do not sync manually (for at lest a couple years now). In order to get them to sync, I need to trigger a manual sync by selecting the list of calendars in the iOS app, and dragging down and releasing. This reliably works to trigger a sync, but I see no setting in the app to sync automatically. Sometimes changing or adding an appointment in the iOS app will also trigger a sync, but not always.

Is there a way to get iCloud calendars to sync automatically with the iOS Calendar app?


I have tried rebooting all devices. Logging off iCloud and logging back in, and restoring and rebuilding the installation on my iOS device. Nothing helps.

1

I had the same problem. I remembered that I was having battery problems, so I switched "Fetch" to manual mode. Even though iCloud is setup as PUSH, the calendar seems to be overridden by the "Manual setting for Fetch.

Settings - Mail, Contacts, Calendars - Fetch New Data - Change Fetch from Manual to one of the durations.

Once I did this, and made a calendar change on the Mac, it was immediately reflected in the calendar on the phone.

0

I belive, you just have to turn on "Calendar" in System Settings > iCloud on all devices you want them to stay in sync.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .