I've got both an iPhone 3GS and an iPod Touch 2G which used to both be able to control my computers iTunes library using the Apple Remote app. However since I've started using a BT Home Hub 2 (A & B) the Remote app has not worked.

I've tried everything to get it going from un-installing iTunes and Bonjour and re-installing, to checking both the software and hardware firewalls. Even with all firewalls off there is no connection.

Has anyone else found a solution to this problem?


May seem like a silly question, but did you changed SSID names when you switched to the new router? If so, make sure you connect both iDevices to the new network's name and reconfigure the Remote app.

Hope this helps!

Edit: Are you able to connect to a website from your devices on the new network? And do you still have the old router broadcasting? I ask because maybe your devices are still connected to the old network, but your PC is on the new one. If you haven't already, try going to Settings >> Wi-Fi, and verifying that the network you're connected to is the same that your PC is on. If so, and it's still not working, reset your network settings and see if that helps

  • The Remote app has been reset and will not even make the initial connection. – Stevo3000 Aug 2 '10 at 8:17

With an older home hub and a pc with vista and iTunes, my only solution was to connect a second vintage wireless router, connect via that, set up the association and then remove the vintage router. It then continued to work when connected via the home hub. I could never establish a connection via the home hub.

  • Unfourtunatly I don't have a working legacy router. – Stevo3000 Aug 2 '10 at 8:18

You must log in to answer this question.