The loading of the installation from a Yosemite USB installer drive is interrupted by a blank screen about ⅓ into the progress bar. The same USB drive works on another (older) MacBook Pro.

The MacBook (8,2 which should be early 2011 but on the back it says 2010) is equipped with a blank SSD drive.

The following boot options had some effect:

  • alt (boot select) allows me to select the USB drive.

  • cmd-alt-P-R (NVRAM reset) had some effect (screen is brighter now), but did not solve the problem.

  • alt-R (internet recovery) loaded all-right, went into the phase where there is the Apple logo and the spinning lines below, and then went blank.

  • alt-D (internet HW test) is executing, but does not find anything but the disconnected battery (battery is dead).

following boot options do not have an effect:

  • cmd-V (verbose)
  • cmd-L (log)
  • D (hardware test) - no surprise since nothing is installed on the SSD

Any clues as to how I can get the machine working?

  • 1
    without battery your system will run at 1/2 CPU power. The charger is not designed to provide sufficient power needed for full operations without battery support. – Ruskes May 20 '15 at 18:43
  • thanks I will try that. In two weeks I will receive a new battery. – tommi_s May 20 '15 at 18:54

I had the same problem. I had to format the ssd in another Mac before I could move on.

  • Yes - connecting things in Target Disk mode is often a great way to wipe a drive or isolate a hardware failure from a software one. Especially if you have a second Mac but not a bootable USB to do the erasing. – bmike Dec 2 '15 at 19:57

Apple has steps to isolate the failure documented at :

Remove everything you can to make a minimal system. (remove all external devices, the SSD/HDD and all but one memory stick). Alternately, you could try placing that Mac into target disk mode and installing the OS from another Mac.

To run a minimal install on that hardware alone, boot to internet recovery or from a netboot server and install onto a known good USB external drive.

If that won't work, you'll need to determine why the logic board in a minimal configuration isn't working.

Sorry to offer vague guidance, but documenting how to diagnose and repair a Mac is far too broad for this site.

  • I disconnected all peripherals including the SSD and DVD, but left the USB with the same result. – tommi_s May 20 '15 at 18:55
  • internet recovery does not work. I did not try target disk mode yet and I suspect it is too complicated for me. The single-user mode seems to work, but I am at a loss as to what really to do there. Some threads suggested to disable the ATI Radeon drivers, but then there is nothing installed here, yet – tommi_s May 20 '15 at 18:58

AFIK....Some steps of the Installation process require heavy CPU usage.

That is why is it required to have full battery and charger plugged in. System will be consuming a lots of power.

In you case "without battery" there is not enough juice to continue with the installation.

It is well published fact that Macs will automatically cut the CPU power in 1/2 if operating without battery, since the charger is not designed to provide full power needed for the operations.

This is a theory, since I have no proof for the statement above.

  • thanks again. just another piece of fact: when using the single-user mode (cmd-S) I can follow the bootup progress after typing exit. The last message before the blank screen is "[AGPM Controller] build GPUDict by Vendor1002Device6760". This would either mean that the graphics processor is shot, or that it consumes too much power for operation without battery – tommi_s May 20 '15 at 19:47
  • I would say it is the power cut, you know the CPU feeds the GPU so now it is starving :) and if completely shot you would not see anything on the screen. – Ruskes May 20 '15 at 20:03
  • Wouldn't a CPU constraint just slow things down instead of leave the machine stuck at the grey screen? What you state isn't necessarily false, but how is it relevant? – bmike May 20 '15 at 20:53
  • @bmike AFIK, it would slow down to a possible halt if the system is not responding. I do not have the detailed power requirement for the Yosemite installation process. However Apple does not says anything about installing it on a system without battery power support. In any case, it is a handicapped system, and my guess Yosemite would get stuck with it at some step. I offer a possible explanation but without prior proof, since I do not know another reason for this problem. – Ruskes May 20 '15 at 23:15
  • I now installed a new battery. Still the same symptom persists. The AHT shows in the hardware profile that the battery is fully charged. The AHT test however still shows a battery error code "4xxx/4/40000005". Now from other threads I am reading that this will disappear if I buy an "original" Apple battery. Now the question is whether there is a software test for battery issues which then disables e.g. the Radeon graphics, or whether the non-original battery cannot deliver. I suspect the former, but it is a 100-EUR bet. :( And the last option is that actually the graphics do not work. – tommi_s May 29 '15 at 16:56

I brought the macbook to an Apple dealer to get it checked. They repaired it under the "MacBook Pro Repair Extension Program for Video Issues", and I did not have to pay for it. This means the culprit was the video card.


I had same problem of progress bar hanging halfway through startup. MBP early 2011. Visited Genius Bar and the guy there said almost straight away he thought he knew what the problem was. Turns out it is the video card. They are going to replace the main logic board and the video card maker is going to stomp up the cost. Apparently on this laptop there is a known issue. I am going to collect unit in a few days so we will see but certainly worth visiting the Genius Bar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .