40

I ran into an issue where my volume buttons on my mac weren't able to adjust the volume of my computer. I sought a solution and someone suggested using sudo killall coreaudiod. Now I have no volume on my computer at all. How do I fix this?

1
  • 1
    I have to kill coreaudiod regularly on Catalina and Big Sur, and it always restarts, working perfectly.
    – benwiggy
    May 1, 2021 at 8:53

6 Answers 6

68

This command will do it:

sudo launchctl stop com.apple.audio.coreaudiod && sudo launchctl start com.apple.audio.coreaudiod

Details

Martin Strouhal's answer doesn't work for OS X/macOS ≥ 10.12.4 due to removal of com.apple.audio.coreaudiod from system integrity protection's RemovableServices whitelist in /System/Library/Sandbox/com.apple.xpc.launchd.rootless.plist [1].

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist
/System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist: _
   Operation not permitted while System Integrity Protection is engaged

So instead of unloading the service, we instead just restart it.

Also, the latter command (sudo launchctl start com.apple.audio.coreaudiod) worked to restart the service after I had killed coreaudiod using killall coreaudiod.

3
  • This is going to relaunch the service actually (I can see the spinner on the bar sound icon, but the output audio device does not come back (I only see the damn SoundFlower). Mar 16, 2019 at 15:02
  • Similarly - Catalina (10.15.7) does not let you relaunch coreaudiod due to "System Integrity Protection".
    – sygibson
    Oct 10, 2020 at 16:14
  • Thanks @sygibson . This inspired me to do a little digging into where exactly and in what macOS version this functionality was disabled. Turns out 10.12.4 onwards won't allow it (see the discussion I added above).
    – ijoseph
    Oct 11, 2020 at 4:57
24

You need to reload coreaudiod instead of killing it. This one-liner will fix broken sound without restarting your mac

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist && sudo launchctl load /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist

7
  • 8
    I can't believe I have to do this several times a day. Jan 21, 2017 at 10:26
  • Nice, worked very nicely to clean up my Airplay connection after adding and removing Soundflower. Apr 13, 2018 at 21:53
  • 1
    I get a service already loaded and nothing actually loads. Mar 16, 2019 at 15:01
  • 1
    @octohedron I can't believe this is STILL broken...
    – Kheldar
    Jan 25, 2020 at 16:06
  • 4
    Operation not permitted while System Integrity Protection is engaged :( Aug 4, 2020 at 5:10
4

sudo killall coreaudiod should work to kill your audio drivers. It should reload itself within a fraction of a second. (verified on my mbp running 10.14 but used this on a couple of previous versions)

1
  • This completely worked for me while other solutions did not. NOTE: I had to do this 3 times before coreaudiod stopped pegging the cpu. (mine was consistently hitting 75% cpu utilization)
    – MER
    Feb 13, 2020 at 23:09
1

You can also use the command:

sudo launchctl kill SIGTERM system/com.apple.audio.coreaudiod
1

I'm using an M1 pro. This is very frustrating so I just created an alias in my .zshrc.

alias ar="sudo pkill coreaudiod -i"

copy paste this line and it will just append+write to your .zshrc or .bashrc

echo 'alias ar="sudo pkill coreaudiod -i"' >> ~/.zshrc; source ~/.zshrc

Or if bash:

echo 'alias ar="sudo pkill coreaudiod -i"' >> ~/.bashrc; source ~/.bashrc

Sadly Still looking for a fix.

Hope this helps someone.

Happy Coding =)

New contributor
White Rabbit is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

I prefer the more modern form using this syntax:

sudo launchctl kickstart -kp system/com.apple.audio.coreaudiod

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .