45

I ran into an issue where my volume buttons on my mac weren't able to adjust the volume of my computer. I sought a solution and someone suggested using sudo killall coreaudiod. Now I have no volume on my computer at all. How do I fix this?

0

6 Answers 6

71

This command will do it:

sudo launchctl stop com.apple.audio.coreaudiod && sudo launchctl start com.apple.audio.coreaudiod

Details

Martin Strouhal's answer doesn't work for OS X/macOS ≥ 10.12.4 due to removal of com.apple.audio.coreaudiod from system integrity protection's RemovableServices allowlist in /System/Library/Sandbox/com.apple.xpc.launchd.rootless.plist [1].

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist
/System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist: _
   Operation not permitted while System Integrity Protection is engaged

So instead of unloading the service, we instead just restart it.

Also, the latter command (sudo launchctl start com.apple.audio.coreaudiod) worked to restart the service after I had killed coreaudiod using killall coreaudiod.

2
  • 2
    On macOS 14.4, you just get Not privileged to stop service. (see my other comment above)
    – luckman212
    Commented Feb 9 at 14:59
  • In macos 14.3, sudo killall coreaudiod works totally fine. Commented Feb 25 at 3:03
24

You need to reload coreaudiod instead of killing it. This one-liner will fix broken sound without restarting your mac

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist && sudo launchctl load /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist

0
6

sudo killall coreaudiod should work to kill your audio drivers. It should reload itself within a fraction of a second. (verified on my mbp running 10.14 but used this on a couple of previous versions)

0
2

I prefer the more modern form using this syntax:

sudo launchctl kickstart -kp system/com.apple.audio.coreaudiod

edit: Apple, in their infinite wisdom, has unfortunately deprecated the kickstart verb for system daemons as of 14.4. Read a bit more in the official release notes. And, they've just closed the Feedback ticket I opened as a wontfix. Sigh.

5
  • 1
    Seems Apple has deemed this "too dangerous" as of macOS 14.4, I am no longer allowed to kickstart my own daemons. Just get Could not kickstart service "com.apple.audio.coreaudiod": 1: Operation not permitted. I filed a ticket in case anyone else wants to hop on: FB13601345
    – luckman212
    Commented Feb 9 at 14:57
  • In feedback assistant, how do I add your ticket (is it possible) Commented Feb 25 at 3:17
  • You can't directly add to my ticket, but if you mention the same bug ID in the notes I believe they get aggregated.
    – luckman212
    Commented Feb 25 at 5:09
  • did what you said. Hopefully the feature is re-added Commented Feb 27 at 7:09
  • Holy crap, did some searching and quickly stumbled upon your Hacker News article, which is number 5 in the search results. Commented Feb 27 at 7:12
1

You can also use the command:

sudo launchctl kill SIGTERM system/com.apple.audio.coreaudiod
1

I'm using an M1 pro. This is very frustrating so I just created an alias in my .zshrc.

alias ar="sudo pkill coreaudiod -i"

copy paste this line and it will just append+write to your .zshrc or .bashrc

echo 'alias ar="sudo pkill coreaudiod -i"' >> ~/.zshrc; source ~/.zshrc

Or if bash:

echo 'alias ar="sudo pkill coreaudiod -i"' >> ~/.bashrc; source ~/.bashrc

Sadly Still looking for a fix.

Hope this helps someone.

Happy Coding =)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .