0

sorry for the long post and my english.

I have an early 2011 Macbook Pro 13 which I purchased in july 2011 and it worked fine until one week ago. Since when I bought it i replaced the stock hdd with a 240G OCZ Vertex 3 and it never had any problems.

One week ago my Macbook crashed while I was working (only the spinning wheel was moving but the system was unresponsive in every other way) so I turned off the computer by pressing the power key. When I turned it on again it showed me a stop sign at boot but after a minute or so it booted up normally. The next day it totally stopped booting, hanging on the stop sign and not moving from there anymore.

I thought that maybe my ssd failed after 4 years of intense use, so I took it to an Apple Store and the Genius told me that they couldn't do anything apart from replacing my old hdd (which is working fine) but they couldn't assure me they would be able to recover my data (my last backup was old).

So I took the stock hdd and installed Yosemite again. The computer booted up normally and started working again. The strange thing was that I was able to look at all my files on the failed ssd (which I put in an external sata to usb enclosure). I tried to repair the ssd because Disk Utility gave me some errors. Then I tried again to boot up from the ssd but I got the stop sign again.

So I did this: I took another ssd drive I had and which I was sure was working fine from another pc (it's an OCZ Vertex2 120G). I cloned my working stock hdd and tried to boot up from the Vertex2: i got the stop sign again and couldn't boot up.

I tried the verbose mode and it didn't gave me any particular message before getting to the stop sign.

I tried the following steps:

  • Reset NVRAM, SMC, PRAM or whatever I could reset
  • Repairing my ssd with Disk Utility and fsck (no errors)
  • Disabling kext-signing, even if I had no TRIM enabled

The last thing I did was to put the ssd in the external sata to usb and try to boot up from there: surprisingly it worked.

I am now writing from my original ssd with all my files. So far it didn't give me any error and is working just fine.

I got in touch 2 times with Apple Support and they told me they had no idea and that it must be a hardware failure (?). However, this explanation makes no sense for all the reasons I listed above.

I am using Time Machine to backup my data but my computer is obviously very slow compared to when the ssd was in the internal slot. I can't use it like this everyday and I need a solution to have it working again.

Any ideas?

0

The problem was a faulty SATA cable. I got a replacement and everything is now working flawlessly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .