0

I need to execute a shortcut key of CMD + =, problem is that the = on my keyboard (non usa, european) it is obtained by pressing the Shift on the 0 (zero) ...

So I tried doing CMD + Shift + 0 but this doesn't work, infact it does something completely different.

In xcode the shortcut is used to "Size to fit content"

Anyone know what the solution is ?

1

You could make your custom keyboard shortcuts.

Adding a Custom Keyboard Shortcut Command Set

Personalize your Xcode experience by adding your own set of keyboard shortcuts. Xcode provides a default set of shortcuts for most menu commands and common text editing commands. Many of these default shortcuts are based on the commonly used Emacs key bindings.

In the Key Bindings preferences pane, choose Manage Key Bindings from the Key Bindings set pop-up menu.

Click the Add button in the lower left of the dialog.

Choose Duplicate or a template option from the pop-up menu.
Name your new command set file.

You can override the default shortcuts by creating a new command set with your preferred shortcuts. This new set is stored in the folder ~/Library/Developer/Xcode/UserData/KeyBindings/ as a property list with the extension .idekeybindings.

source:https://developer.apple.com/library/ios/recipes/xcode_help-keybindings_preferences/articles/AddingaCustomKeyboardShortcutCommandSet.html

  • 1
    Thanks, but apart from reconfiguring the key. It would be impossible on my keyboard to execute CMD + = (as = requires the shift key) ? – Martin May 20 '15 at 1:31
  • as said, make a NEW shortcut for that function, obviously without the "=", and use something else. – Ruskes May 20 '15 at 1:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .