3

I’ve just started using iTunes U on my iPhone 3G running iOS 3. For some reason, they are all mixed up in my songs on my iPhone, rather than another section such as podcasts which would be far more logical.

In iTunes, they appear in the iTunes U section. Is this meant to happen? If not, how can I fix it?

2 Answers 2

4

Changing the "Media Kind" to "iTunes U" under the Options tab of the "Get Info" dialog will move them from the Music section of your library to the "iTunes U" section.

This tends to happen when you import/rip audio files (audiobooks, podcasts, iTunes U, etc.) to iTunes rather than subscribing to them or buying them through the iTunes interface.

3
  • They are already marked as iTunes U in the media kind
    – Casebash
    Jul 30, 2010 at 23:04
  • 1
    I have "iTunes U" hidden under the General tab of the Preferences dialog. If the category isn't visible, it might cause the episode to show up elsewhere. I'd try - editing your library, resyncing and rebooting the iPhone a couple of times to see if the Music app rebuilds the library (my library needed this after troubleshooting another question yesterday). - I'd update to the latest version of iTunes. - I'd try switching the Media Kind (not genre) to podcast and see if it shows up with your podcasts and then change it back. If none of that works I'd try filing a bug with Apple.
    – SpecKK
    Jul 31, 2010 at 0:31
  • 1
    Just to reiterate without it getting lost, people often mistake Genre for Media Kind. Genre is a standard IDV3 tag, and won't move your media. The Media Kind seems more internal to iTunes and will properly categorize.
    – SpecKK
    Aug 11, 2010 at 1:32
2

I think this answer may apply to your problem as well.

1
  • Link is now broken due to gadgets site being closed :-(
    – Casebash
    Sep 16, 2010 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .