0

I've tried lots of different solutions to get these two working nicely together.

So far I've tried:

  • Re-Pairing the devices

  • Removing and recreating all the Bluetooth plist files

  • Executing (defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" 53)

Nothing seems to fix the drop outs in the audio. I was experiencing it while watching Netflix but I've just tried iTunes and that does the same thing.

Works fine when paired with my iPad Mini.

I bought the speaker shortly after getting the MacBook and it originally worked flawlessly, then an Update to OSX took out BT and WiFi, and got that fixed by deleted the plist files.

After the update to Yosemite nothing seems to fix it. It makes listening or watching anything but a pleasure and is actually now very annoying.

What should my next attempt be at fixing this?

1

I've had some success by installing XCode, then installing the associated hardware IO tools, which include the bluetooth explorer. The bluetooth explorer makes available tools..audio options, which lets you tune some settings.

The settings I found useful were to increase the bitpool (which appears directly related to audio quality), and to increase the buffer packets, which appears to make it more tolerant of temporary dropouts. YMMV.

  • Ahhh, interesting. I've got XCode installed for builds already so I'll check that out. Thanks. – Jammer May 25 '15 at 8:20
  • To be fair, I'm still getting problems - mine works well for a while, then it'll do a burst of (loud) static and just give up. It's better than before I tweaked it, but something's still causing it to just lose connection. I'm probably going to just move to using iPad or iPhone most of the time, although I'm sure there are options in there that could over time give me an OK answer. – PaulL May 25 '15 at 20:16
  • Sorry if it's obvious but did you try resetting you SMC? – Jammer May 25 '15 at 22:01
  • To be honest I think I've actually tried setting that with a sudo command from the terminal and it made my problem worse ... – Jammer May 25 '15 at 22:05
  • Yeah, there are more options in the XCode explorer - you can in particular set buffer packets which I haven't seen people setting via terminal (although you may have done so). I did try the SMC a couple of times....I think it's just my bluetooth dropping out. I suspect it's signal strength and interference related - I'm considering getting a wifi connection to the stereo instead, notwithstanding that would require a special app. – PaulL May 25 '15 at 23:50
0

I've just gone through this process for a second time but the last action I performed was a complete reset of the SMC.

After then re-pairing the MacBook to the UE Boom it seems the drop out issues have in fact gone completly.

How to reset your SMC

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .