0

I use Time Machine to create incremental backups to an external USB hard drive. Backups used to complete properly, but now Time Machine wants to backup much more data. Instead of the couple of GB of new data, the Time Machine menu bar icon popup menu reports it is going to backup 400+ GB! I stopped the backup as soon as I saw this to avoid filling up my backup drive. This is the relevant part of the backupd log:

18/05/15 21:05:06,778 com.apple.backupd[11380]: Starting manual backup
18/05/15 21:05:07,004 com.apple.backupd[11380]: Backing up to /dev/disk1s2: /Volumes/MacBackup/Backups.backupdb
18/05/15 21:05:15,385 com.apple.backupd[11380]: Will copy (22.3 MB) from Macintosh HD
18/05/15 21:06:04,176 com.apple.backupd[11380]: Will copy (Zero KB) from Data
18/05/15 21:06:04,225 com.apple.backupd[11380]: Found 761313 files (380.84 GB) needing backup
18/05/15 21:06:05,392 com.apple.backupd[11380]: 406.52 GB required (including padding), 904.71 GB available
18/05/15 21:06:48,246 com.apple.backupd[11380]: Copied 550 items (22.2 MB) from volume Macintosh HD. Linked 3201.
18/05/15 21:07:38,107 com.apple.backupd[11380]: Copied 123 items (1.57 GB) from volume Data. Linked 165.
18/05/15 21:07:38,738 com.apple.backupd[11380]: Backup canceled.

For some reason, backupd reports it will copy "(Zero KB)" from the Data partition (on an external eSATA hard drive). The output from tmutil compare shows that less than 4 GB needs to be backed up:

Added:         3.6G
Removed:       26.3K
Changed:       292.2M

When ejecting the Data disk, Time Machine does backup the internal hard disk as it should (some tens of MB).

I have a feeling this could be related to the fact that the Data drive was not properly ejected one or more times. Disk Utility's "Verify Disk" reports no problems with the disk however. Also the backup disk is clean.

I think I ran into this problem once before, but then I didn't abort the backup. The backup drive filled up quickly to the point where no new backups could be made. The solution then was to erase my backup HD and configure it as a new backup disk (losing all existing backups).

How can I fix Time Machine to perform as before without having to erase the backup disk and start from scratch? I don't want to be forced to do this every couple of months.

UPDATE I haven't seen this behavior in a long time now. Perhaps it was a bug fixed in a macOS upgrade...

1

EDIT I noticed this seems to happen randomly. Sometimes, Time Machine will start to back up the 400+ GB. At other times, it performs a normal incremental backup. So, I am not sure the procedure listed below really has any effect. I'll leave the description there just in case...

When the external USB HD is connected, I now simply check Time Machine when it starts to backup. If it wants to backup the 400+GB, I simply "Skip" the backup. If not, I let it continue. Not a perfect solution by far, but it works for me.


I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD (and the TM preferences windows no longer listed the WinData partition in the list of excluded items).

At that point I reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .